How to use resedit for intel fortran

How to use resedit for intel fortran


Can anyone help me out on how to include the resource file generated by resedit into intel visual fortran?

I couldn't seem to make it work..

I tried making a dialog in resedit and then added the .rc and .h file in my solution in visual studio. 

I then added a custom build setup for resource.h using steve's guide below:


Steve Lionel (Intel) wrote:

ResEdit should generate both a .rc and a .h. You will need to add both of those to your Fortran project and add a custom build step for the .rc:

  1. Add Resource.h to your project using File>Add Existing Item....

  2. Select the Resource.h file in the Solution View and the select View>Property Pages from the main menu bar.

  3. Set the Command Line option to use the deftofd tool by entering:

    deftofd resource.h resource.fd

  4. Set the Description option to Generating Fortran include file...

  5. Set the Outputs option to resource.fd.

  6. Click OK.

Problem is i couldn't compile my program successfuly. I always get the following error:

Error 1 fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt LINK

It would be nice if someone could post a complete guide for beginners in using resedit in intel visual fortran..

Thanks in advance. ^^ 

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

That doesn't sound to me like  a resource/resedit issue. Try doing a 'clean' and then a full 'rebuild' it sounds like an obkect file is corrupt.

As a matter of interest I assume the fortra fd must be could or else you would have had comple errors. Did the resource file compile OK also?

yeah.. it did compile OK. 

I attached my project file below for reference. 


Downloadapplication/zip qwin1.zip7.54 KB

I downloaded and built your project, other than adding the include file path (C:\Program Files\Microsoft SDKs\Windows\v7.0\Include) for windows.h as it was not default in my environment it built OK with no problems and it runs OK also.

I can't see any problem  did you do a clean? Or perhaps download your project into a new folder and build that to have a clean start. I think you may have some damaged files perhaps?

Have tried doing a clean build and trying to create a new project but I'm still getting the same error..

I'm guessing something's wrong with my configuration in visual studio....

I am not perhaps the right person to help further on this is there any more info details of the specifics of the error, do a full build and post the build log perhaps?

Leave a Comment

Please sign in to add a comment. Not a member? Join today