Problem Installing Visual Fortran 11.1

Problem Installing Visual Fortran 11.1

I need Intel Fortran 11.1 for compiling a software. To find out if I could follow the procedure described by the vendor, I installed evaluation version of a) Microsoft Visual Developer Studio 2008, and b) Intel Visual Fortran 11.1. To get professional version of Fortran 11.1, I purchased Intel Visual Composer 2013 for Windows and installed it on my computer after uninstalling the evaluation version of Fortran 11.1 but not the Visual Studio 2008. Once the date for using evaluation version of Visual Studio expired, I uninstalled Visual Studio 2008 and Intel Visual Composer 2013.

After resolving some downloading issues, last week I downloaded “w_cprof_p_11.1.072.exe” and installed it on my computer (64-bit Windows 7 operating system). Using Visual Studio, I opened a Main Program Code (Console Application), as shown in Page 1 of the enclosure. The configuration manager shows “Win32” as shown Page 2 of the enclosure. It does not let me select 64-bit version.

Ignoring all these, if I try to compile, I get the error message shown in Page 3: “Configuration ‘Release|Win32’ requires compiler support for the ‘Win32’ platform, but that support is not installed. Please either install the compiler support for ‘Win32” or select another configuration. I have not been able to find out how to select another configuration. I will appreciate if you could give me instructions for selecting 64-bit complier configuration and resolve the compilation/configuration issues.

Downloadapplication/pdf fortran11errormessages.pdf620.17 KB
32 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The message:

...Configuration ‘Release|Win32’ requires compiler support for the ‘Win32’ platform, but that support is not installed...

means that you don't have a 32-bit version of the compiler. You could try the Repair option of the installer and verify that all check boxes for 32-bit software selected.

In Visual Studio 2008, you must install the X64 option as well as the default 32-bit C++ in the C++ installation menu so that you can make use of the X64 project switch and the Intel64 compiler.  If this is the problem, you will need to return to the VS install menu, add that component, reapply service pack, and then repair your Intel compiler installation.

Later versions of VS will install X64 language support automatically when running on 64-bit Windows, but VS2008 requires you to select it from the install menu.

Hi Tim,

Thank you for responding to my posting. I don’t have Microsoft Visual Studio 2008 installed on my computer. So, I downloaded “w_cprof_p_11.1.072.exe” as it comes with X64 version of the compiler and “Microsoft Visual Studio 2008 Shell and Libraries”. My understanding is that with this version of the Fortran 11.1 compiler provides GUI for editing and compiling Fortran codes.  The “w*.072.exe” installed “Microsoft Visual Studio Shell (integration mode)- ENU” on my computer. As I did not install VS2008 separately, I don’t see the option for going back to the VS install menu and add the suggested components. The “Uninstall or change a program” menu is shown in the enclosure. It gives the following options only: a) Will be installed on local hard drive, b) Entire feature will be installed on local hard drive, and c) Entire feature will be unavailable.

I am not sure how to proceed from here.  The “w*.072.exe” created two folders under “C:\Program Files (x86)\Intel\Download”:  a) “w_cprof_p_11.1.072” and b) “w_cprof_p_11.1.072_intel64”. Should I use “Setup.exe” in the second folder (*_intel64) to reinstall the compiler? I will appreciate if you could give me suggestions for fixing the problem. Thank you very much.


Downloadapplication/pdf fortran11-041013.pdf355.91 KB

If you have kept the expanded downloaded files, I expect you could use the setup.exe in the intel64 folder to repair or install the 64-bit Fortran. Sorry I didn't catch on that you intended to use the VS2008 shell, which would cancel my comments about installing C++.

Hi Tim,

The “setup.exe” under “intel64” does not give options for repair, as shown in Page 1 of enclosure. So I selected option for installing the components. This step was of no use. So, I uninstalled the compiler, and installed it again for the configuration shown in Page 2. Only improvement is that “x64” appeared in the configuration manager, see Page 3. However, compiling gives the massage shown in the same page: “Configuration ‘Release|x64’ requires compiler support for the ‘x64’ platform, but that support is not installed. Please either install the compiler support for ‘x64’ or select another configuration”.

Please NOTE that I am only installing Intel Fortran 11.1 using executable downloaded from Intel, and nothing else. Intel’s website states that Visual Studio 2008 shell is included with the downloaded file. So the questions I have: WHO is going to install “compiler support for the ‘x64’ platform. Why is the setup from Intel NOT installing the support it needs for Intel’s Fortran program? Please provide detailed instructions on how to correctly install Intel Fortran 11.1 on Windows 7. The release note and other documents do tell me any thing that I have not tried.

For the last two weeks I have been trying to go to website of Intel Premier Support. Every time I enter my login information and password, I get “Server Error in ‘/premier’ Application”. Please see Page 4 of the enclosure and provide instruction on how I can get Premier Support.



Downloadapplication/pdf fortran11-041013.pdf1014.75 KB

Do not use the _intel64 setup. I suggest you uninstall Fortran and all of the Visual Studio 2008 components, reboot, then reinstall from w_cprof_p_11.1.072

Retired 12/31/2016

Hi Steve, I have followed you suggestion a) uninstall Fortran and all of the Visual Studio 2008 components, b) reboot the laptop, and c) reinstall from setup in w_cprof_p_11.1.072 folder. Unfortunately, I am still getting the same message: “Configuration ‘Release|x64’ requires compiler support for the ‘x64’ platform, but that support is not installed. Please either install the compiler support for ‘x64’ or select another configuration” (see Page 3 of previous enclosure). The Visual Studio 2008 components that I had are shown in the enclosure. I uninstalled a) Microsoft Visual Studio 2008 Remote Debugger – ENU, and b) Microsoft Visual Studio 2008 Shell (integration mode) – ENU. I did not uninstall “Microsoft Windows SDK for Visual Studio 2008” components, as listed in the enclosure. Should I be uninstalling these components also? If I do, will the setup for Intel Fortran install these components that other program may need? Could you tell what “compiler support for the ‘x64’ platform” mean? Where should it be coming from? I will appreciate your suggestions. Thank you very much.


Downloadapplication/pdf fortran11-041113.pdf277.22 KB

What this is looking for is the Microsoft tools and libraries for 64-bit development. This is supposed to be provided by the installer you used. That is pretty old at this point, and I know there were some issues regarding the shell a while ago. Can you choose a more recent version? You'd need to uninstall all those components again. The SDK can stay.  Did you have any other version of VS2008 installed previously, such as Visual C++ 2008 Standard Edition?

Retired 12/31/2016

Hi Steve,

Thanks for quickly getting back.

Unfortunately, I cannot use a newer version of Fortran compiler and/or Visual Studio. We are using a software that has not been updated. The vender will eventually do it, but not now. I do not have a choice. I have to use Intel Fortran 11.1 and Visual Studio 2008 Shell.

Earlier this year to find out if I could add new subroutine to the software, I had installed the evaluation version of a) Microsoft Visual Developer Studio 2008 (Product Version 9.0.21022.8), and b) Intel Visual Fortran 11.1. I had to install the Visual Studio 2008 as the evaluation version of Fortran 11.1 does not come with shell integration. I was very pleases that everything worked seamlessly without any hitch.

To get professional version of Fortran 11.1, I purchased Intel Visual Composer 2013 for Windows and installed it on my computer after uninstalling the evaluation version of Fortran 11.1. At this stage, I did not uninstall Visual Studio 2008. Once the date for using the evaluation version of Visual Studio expired, I uninstalled both Visual Studio 2008 and Intel Visual Composer 2013.

Then the problem started. You may recall, I took me more than a week just to log in to correct website to download the professional version of Fortran 11.1.

The answer to your question if I could chose more recent version is NO.

YES, I had installed evaluation version of VS2008 (Product Version 9.0.21022.8), but I am not sure if it installed Visual C++ 2008 Standard Edition.

It appears that my computer has the several versions of Microsoft Visual C ++ 2008 Redistributable -64 (as well as x86). The x64 (as well as x86) version numbers are: a) 9.0.30729.17, b) 9.0.30729.418, and c) 9.0.30729.6161.

I will appreciate if you could review the above information and give me some ideas that I hope will resolve the compiler problem(s).

Thank you again.

The redistributable packages should not be an issue. My guess is that something left over from the VS2008 install is messing things up. But I wasn't asking you to use a newer full version, just the latest 11.1 you can get (which is 11.1.078 or something like that.) It would at this point be the only one available from the Intel Registration Center. If you could try that, you'll need to uninstall Fortran and VS2008 Shell again.

If that doesn't work, let me know and perhaps next week I can connect to your system and see what is going on.

Retired 12/31/2016


Where do you keep 11.1.078 version? I cannot find it. When I login, the latest verson that shows up is 11.1.072, as shown in the enclosure. If there is a 11.1.078 version, could you please send me the link to the website directly. Thanks.     

>>... If there is a 11.1.078 version...

I also don't see that version.

>> to the website directly...

Even if Steve provides you with a link you won't be able to see that web-page because it will be a secure link. You need to be logged in with a right user name and password.

Sorry - my error. 11.1.072 is the latest  Also I removed your PDF as it included your serial number.

Can we set up some time next week for me to call you and connect to your system? Send me mail at steve.lionel at intel dot com and suggest some times you'll be available (please include time zone and phone number.) Perhaps I can figure this out if I see what's happening first hand.

But try this. You have access to the 2011 product.  Uninstall everything. Download and install Composer XE 2011 Update 5 (not 6 or later) WITH the shell.. Check to see if that works. Now install 11.1.072 on top of that - you'll be using the VS 2008 Shell from the 2011 product. In VS, select Tools > Options > Intel Visual Fortran > Compilers. You should now be able to select 11.1 as the compiler version. See if this works.

Retired 12/31/2016


Composer XE 2011 Update 5 setup file that I can find is "for customers who have Microsoft Visual Studio alrady installed". The file name is "w_fcompxe_novsshell_2011.5.221.exe". Will it give me an option for installing with the shell? Appreciate an early response so that I can test out you suggestion before Monday. Thanks.  

Withdrawing my last posting. My mistake. Found it.


I followed you suggestions of uninstalling everything and installing Composer XE 2011 Update 5 and then installing Intel Visual Fortran 11.1.072. Not sure if the results will surprise you.

To start the process, I uninstalled a) Microsoft Visual Studio 2008 Remote Debugger – ENU, b) Microsoft Visual Studio 2008 Shell (integration mode) – ENU, and c) Microsoft Tools and Libraries for Intel Visual Fortran.

I restarted my computer and installed Intel Composer XE 2001 Update 5 for Windows. Page 1 of the enclosure shows the version and update information (2011.5.221) from Control Panel of my computer. Pages 2 through 4 show that the Composer was not correctly installed: a) VS2008 does not recognize *.vfproj type file (Pages 2 and 4), and b) VS2008’s option panel does not list Intel_Composer_XE (Page 3).

Not knowing what to do next, I restarted my computer and installed Intel Visual Fortran 11.1.072. Page 5 shows the version number appearing in control panel of my computer. Now VS2008 recognizes *.vfproj file type and I could open and compile a Console program. The strange thing is that the Option panel shows “Intel® Composer XE 2001 Update 5 build 221” only (see Page 6). Installing Fortran 11.1 fixed problems with Composer XE 2011!!!!

As suggest in you last posting, I will directly contact you and set-up a date and time for reviewing the issues with Intel Fortran Composer or Compiler.



Downloadapplication/pdf fortran11-041513.pdf1.6 MB

I think I understand what happened. Yes, a project that was created with Composer XE 2011 probably would not open with the 11.1 integration.

Is something still not working?

Retired 12/31/2016

I got Evan going again - the problem was that the initial install of the 2013 compiler left files around that the 11.1 install couldn't override.  The solution is to use the "Newer version already installed" instructions in How can I use older versions of the compiler with different versions of Microsoft Visual Studio*?

Retired 12/31/2016

Steve: Thank you very much. I appreciate you time and help. 


I'm also having a problem with installing Visual Fortran 11.1 and was hoping someone could help me work it out. I have a disc with 11.1.048 Udate 2. I have VS2012 Professional already installed on a Windows 7 x64 machine. When I click Next on the Welcome screen for the Fortran installer I get the following message:

Intel(R) Visual Fortran Compiler Professional Edition for Windows* installation can continue, but take note

  The following components can not be installed:
          - Intel(R) Visual Fortran Compiler for applications running on IA-64
Installation can continue; however, these components will not be installed because they require that a supported Microsoft* development tools be installed. Refer to the Release Notes for a list of the required Microsoft* development tools.

I realize this is an old version, and it appears as though it would do a limited install at this point, but I need to do 64-bit development with this tool and that doesn't appearto be an option. I followed the link to the document for using older versions of Fortran and that doesn't appear to have a solution to my problem.

Any ideas on how to proceed? Would installing from w_cprof_p_11.1.072.exe get around this problem?


Also - where would I download w_cprof_p_11.1.072_intel64.exe (I think that's the one I want) or w_cprof_p_11.1.072.exe?

Thanks again...

OK. I figured out how to get to the registration center and afte renteing my serial number it says that my license has expired (not surprising) but that I will have to purchase a renewal license (which will be back dated to 09 Feb 2011) in order to download it.

Is this the only way to get this file? I also tried to generate an unlock code should I get the package and that also says my license is expired and will not give me an unlock code.

Is that the answer, or can I just get a several year old update t my software to see if I can use 64-bit compilers? Or does anyone have an idea fo a fix with the disc I have?



OK. Sorry. I guess I should have gone further. I finally decided to install as is and worry about 64-bit operation later. What I found is that the installer distinguished between IA-64 and Intel x64 and is installer the latte because that's what I have. The new problem is that it can't see VS2012 but wants to install the VS2008 Shell and integrate to that. I assume I'm pretty much stuck doing that and repairing the whole thing later. Can anyone point to instructions on how to get this integrated into VS2012 after installation?


If your license expired prior to the release of vs2012 support you will not be able to download an ifort which recognizes vs2012. If your license expired over 2 years ago renewal might cost more than a new purchase.

Tim is correct that the version you are licensed for doesn't support VS2012.For renewal information, see but if 11.0 is the latest you are eligible for, you won't qualify for renewal pricing.

"IA-64" is for servers with Intel Itanium processors. Version 11.1 was the last version to support that line. In most cases you want "Intel 64" (also known as "x64").

Retired 12/31/2016

Thanks all.

I know it's the wrong place to ask, but I went ahead and installed with the VS2008 shell and I'm getting some odd compile errors with what should be working code (is was working when last checked into the repository).

THe compiler seems to be hanging up on "class" no matter where or how it finds it. So, for instance, there is a variable named class_dist. Anywhere this variable is used the compiler generates an #5082 syntax error, found IDENTIFIER '_DIST' when expecting...

That happens repeatedly in the same or similar fashion. As another example, there is a variable "classify" and the error is identified as the keyword 'IF' as opposed to 'IFY' because once the compiler finds class it appears to be parsing that line for any other keywords it can find.


I suspect this might be an IDE error as opposed to a compiler error. I'm sure it's a setting somewhere, but I haven't been able to figure it out yet. As I said, if you can point me to the right place to ask his question I'd appreciate it, but any suggestions would be appreciated.


Thanks again.

Merrick, that sort of thing is a compiler issue, never an IDE issue. I know we have found and fixed similar issues in the past, so I'd encourage you to try a more recent compiler. I see in our records that we fixed a problem like this in 11.1

As for the place to ask, this forum is fine, but please start a new thread rather than tacking on to an existing thread unless you're convinced it's the identical issue. This makes it easier for others to find questions of interest to them.

Retired 12/31/2016

Steve, thanks. I have 11.1.048 (on the disk) but couldn't get the update because the license is expired. A person working on the project before me did generate unlock codes for at least two updates one of which is 11.1.060, but I have not been able to find the downloaded code.

Actually, we have two brand new server licenses but out IT folks haven't been able to install them yet, so I'm just trying to familiaize myself with the code as much as I can until those licenses are available.

Thanks again...

Could I get intel visual fortran 11.1 compiler as i do have license for composer XE 2013


See Tim's response in your other thread.

Retired 12/31/2016

Leave a Comment

Please sign in to add a comment. Not a member? Join today