Qopenmp-link:static not supported

Qopenmp-link:static not supported

Hello,

for an older version of IVF (11.1.xxx) i had the need to add the following option: Qopenmp-link:static.

Using the current version (13.1.1.171) i get the warning 'Qopenmp-link:static not supported'.

For the old version i explicitly needed the option to include the needed 'MP' files into the exe-files. Are those files automaticlly included with the current version?

Thanks in advance

Frank

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

For our Windows compilers, the OpenMP library is now provided in DLL form only. This is called out in the release notes. There have also been warnings in the release notes in some previous versions (though not as far back as 11.1) that the static library was going away.

Retired 12/31/2016

Hello Steve,

the change from lib to dll is one point. The other is, is it needed to add those dll files if i distribute the exe file or are all needed parts from those dll files added to the exe file?

Thanks in advance

Frank

You need to distribute the DLL separately.

Retired 12/31/2016

Sorry, it is not possible. But you should just be able to copy libiomp5md.dll alongside your EXE. You don't have to use the msi. Nothing else is needed.

Retired 12/31/2016

Leave a Comment

Please sign in to add a comment. Not a member? Join today