msobj80.dll error with new project not old one

msobj80.dll error with new project not old one

My intel fortran was uninstalled for a while and recently installed again.  When using MVS 2008 version 9 (the shell that comes with Intel Parallel Studio XE 2011) , I created a project, compiled it, and tried to debug it.  I got the msobj80.dll error.  Saw the solution on your web page.  Failed to have privleges to copy dll to

C:\Program Files (x86)\Microsoft Visual Studio 8\Common7\IDE

I notice that if I open an older project with with the SAME MVS 2008, it works fine.  What's up with that?  It was supposed to be a path problem.  Is there something I can do to get the new project to debug that does not require admin privleges?  Any advice would be greatly appreciated.  Thank you. 

12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Didn't ifort XE2011 install VS 2010 shell?  I would not be surprised if the VS shell needs to be the one provided with the compiler.  I suppose it can be tricky to install simultaneously different versions which require different VS shell versions.

I do not see MVS 2010 in the intel program group.  Another problem is that I installed intel BEFORE installing Microsoft Visual Studio 10.0 Pro.  This I did to get acces to the C compiler it comes with.  So, double problem of intel's compiler not being associated with that.  I would, howeve, be fine with getting the mvs 2008 shell working.  

If you repeat the ifort installation after VS Pro is present, it should correct the integrations; XE2011 should use VS2010 Pro.  ifort doesn't "come with" any C other than the one furnished by VS Pro (or by adding Intel C++).  If you have Intel C++ that also would pick up integrations with supported VS if installed after VS.

As an intermim fix I had IT copy the dll C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\Bin\amd64

To here:

C:\Program Files (x86)\Microsoft Visual Studio 8\Common7\IDE

I still get the same error upon compiling the debug version.  Before going back to IT hat in hand, is there something a non-admin priv user can do to fix this?  Maybe add the path as an environment variable in the project itself?  Please let me know.  thank you.


The VS2010 Shell was added in Update 6 to the 2011 version.

Try this. In Visual Studio, select Tools > Options > Intel Visual Fortran > Compilers. On the Win32 tab, cliick Reset... Repeat this on the x64 tab.  Close and reopen Visual Studio.

Steve - Intel Developer Support

I did as you suggest and received the same error upon building the debug version of the program.  Thank you for the suggestion, however.

Please have your system administrator copy the DLL NOT in the "amd64" folder into the specified folder. The one in amd64 is not correct for this purpose.

Steve - Intel Developer Support


My IT admin is unable to run the product update of the Intel package.  I had hoped that this would incorporate the compilier in the 2010 Visual Studio Pro that was installed on my computer after Intel was installed and fix the msobj80.dll problem.  How do I run the update?  It seems to need a file and has been too long for me to remember what was done last time.  Please let me know.  Thank you.


Please provide details of what goes wrong (error messages, etc.) and what file is "needed", Also, please tell me the exact and complete file name of the update executable that they tried to install.

Steve - Intel Developer Support

Dear Steve;

Details: I am still unable to debug a project under the VS2008 shell provided with your compiler.  I had seen the possible solution to copy the msobj80.dll from one place to another.  As you had mentioned, this was the wrong idea.  I do not believe my IT has undone the copying of that dll yet.  I had thought that using the product update option from the Intel start menu group would be a good idea as that may incorporate the compiler into my VS2010 pro installation and possibly fix the copyong of the dll.  Unfortunately, when my IT man uses this function, it does not retreive the file needed to update the package.  It would seem that the user must first go fetch the update file himself.  So, my question above was, 'How do I do this?'  Where do I go to retreive the file in order to run the update of the compiler?

You see, nothing is terribly obvious in using this product in terms of support.  I have a hard time just weeding through the intel noise to get to your fortran group.  Had I to find it again, I would not know how to get to the premium support page I had used.  This business with trying to update the compiler so it will get incorporated back into the VS2010 is really tough.  I did find something while searching through intel's web page.  One submits the serial number from the box and available product updates are shown.  I told IT to uninstall the product and re install it and then follow the info I found that talks of providing the serial number. 

Please point me to a reference or spell out how one should update the software.  As for the failure to debug because of the msobj80.dll: I reckon installing VS2010 pro after having installed the intel compiler is what caused that problem. 

Please let me know.  Thank you.



I'm not sure what more we can do to make the support options clear. The documentation points to support, the release notes point to support. Even a Google search for "Intel Fortran support" shows promising links in the first few results. How did you try to find it?

As for updates, you simply install the newer version. You still haven't told me what went wrong or what your IT department tried to install.

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today