OPEN: FILE - file name missing or blank

OPEN: FILE - file name missing or blank

Hi,

I´m converting an application from Compaq Fortran to Intel Fortran and so far it is going very well (http://software.intel.com/en-us/articles/migrating-from-compaq-visual-fo...).

The only problem is with "Open" command. When I´m running the program in Debug Mode of visual studio, the console prompts the user to specify a filename. (That behavior is OK to me) When I execute the release version, the console does not prompt me to specify the filename, and the execution fails.

I have tried also to execute the release version passing the filenames as command line arguments (http://software.intel.com/en-us/node/465364) , but it is not working also. I don´t know if I am doing something wrong with the syntax, like using double quotes.... I have tried all combinations..

Can Steve Lionel help me? How can I build a release version that has the exact same behavior with Open command.?

ps: Sorry for any english mistakes...
ps2: I´m using Visual Studio 2008

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

In the project properties with the Release configuration selected, go to Fortran > Compatibility. Set the property "Use Filenames From Command Line (PowerStation)" to Yes. You have this set in the Debug configuration but not in Release.

Steve - Intel Developer Support

Exactly what I needed! Thanks

Leave a Comment

Please sign in to add a comment. Not a member? Join today