Type KIND of PARAMETER lost when used as TRANSFER MOLD

Type KIND of PARAMETER lost when used as TRANSFER MOLD

The following two statements does *not* produce the same result:

PRINT *, KIND( TRANSFER(real_num,equal_size_int) )
PRINT *, KIND( equal_size_int )

where equal_size_int is a PARAMETER accessed through a MODULE.

This must be an error...

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Did you perhaps mean to write:


? What you have is just an integer whose value is equal_size_int with default kind.

Steve - Intel Developer Support

equal_size_int is the name of the integer parameter, it can have any value and is not intended as a kind parameter (which would have to have the values 1, 2, 4 or 8 in IFORT)

But regardless of that, shouldn't the two statements produce the same result?

Please show me a complete source that demonstrates the problem. I can't see it from those two lines.

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today