compiling error Windowssdkdir not found

compiling error Windowssdkdir not found

Hello ,

I am new user of intel fortran compiler. When I open command prompt for compiling fortran77 code it shows an error that is 'WindowsSdkDir not found'

I am using visual studio 2008 and intel fortran compiler 11.1.072 .I followed all the instructions which was previously discussed in this forum.

(i.e set a variable path for windowssdkdir ,then I uninstalled the both VS2008 and compiler then I installed VS2008 first and followed by compiler but still showing the same error.)

1. I am using 64bit machine with XP platform. are there any perticular things which we need to take care while installing both the vs2008 and compiler?

What is strange to see that when  I installed VS2005 and intel fortran compiler 9.1 then it works properly.

2. I have some make files which were compiled already in 11.1 , is it possible that same make file I can use it to compile it in version 9.1 or any modification is required?

Please find attached ppt. to see the screenshot of error.

Can you please help me on this issue.

Thanks in advance.

Downloadapplication/ problem.ppt80 KB
11 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Which edition of VS2008 is this? Standard? Express? Professional? If Professional or higher, did you select a Custom install and select the "x64 compiler and tools" as directed by the Fortran release notes?

Retired 12/31/2016

Hello steve ,

VS2008 professional edition.

I selected full installation of the VS2008 and then integrated with intel fortran compiler 11.1.072.

You will need to do the following:

1. From Control Panel > Add or Remove Programs, select “Microsoft Visual Studio 2008”
> Change/Remove. The Visual Studio Maintenance Mode window will appear.
Click Next.
2. Click Add or Remove Features
3. Under “Select features to install”, expand Language Tools > Visual C++
4. If the box “X64 Compiler and Tools” is not checked, check it, then click Update. If the
box is already checked, click Cancel.
5. Uninstall and reinstall Fortran.

Retired 12/31/2016

I did all this which you have told,but still no succes.  'x64 compiler and tools ' box were already checked in. I uninstalled and reinstalled fortran then also it is showing the same error.

Help on this issue. 

Hello ,

I did all the things which you have mentioned. 'X64 compiler and tools'  was already checked.

Then I uninstalled and reinstalled the fortran.

still no success.

Can you please help on this.What is goining wrong?


Search your system for a file named kernel32.lib  You may have multiple copies of it, but it should be in a folder with a name similar to C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\lib  (There will also be an x64 subfolder with this library). Copy the path to this folder and go into Tools > Options > Intel Visual Fortran > Compilers > Library Files. Add a new line and paste in the path to the folder you found. Click on the x64 tab and add the same line, but add \x64 at the end. Click OK.

See if this fixes the problem.

Retired 12/31/2016


There are multiple Kernel32.lib files.

I don't have folder called  v7.0A instead of that I have files v5.0 and v6.0A.

v5.0 have only Include and lib folders.

while V6.0A have everything.

Please find attached ppt. which has screen shot of current paths. which you have mentioned.


Downloadapplication/ problem.ppt163 KB

Replace the line that has WindowsSdkDir with the path to the 6.0A\Lib\x64 folder

Retired 12/31/2016

Finally got success.

Changed platform from XP to Win7.


Leave a Comment

Please sign in to add a comment. Not a member? Join today