Solution Explorer files no longer load automatically

Solution Explorer files no longer load automatically

After things were for a long time working swimmingly, something must have "slipped".  Suddenly, without warning, when I open an IVF Solution (*.sln), the IDE comes up and the f90 source file names appear in the Solution Explorer panel (upper right-hand corner).  But they no longer load automatically.  I have to individually click them one at a time to load them into the main pane. Earlier, they'd load automatically when the SLN was opened.

What toggle did I accidentally hit?

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

That sounds like a problem I have had periodically. If you look at at the <solution name>.suo file is it getting large (few megabytes?). What I have found is that it is including bookmarks for the edit files over and over many hundred/thousands of times. After a while the solution load gets slower and then it starts giving problems like  you describe. 

I can't remember exactly how I fixed this but there are some threads around that describe it. From recall I deleted the SUO file but is gets remade from a VS text based settings file. I think one solution was to edit this settings file to delete a zillion bookmarks or the was a 'reset' type option. I will look for a thread and post it. 


google "Visual Studio 2010 does not reload open files" there is a thread on

Thanks for your remarks, app4619.

Firstly, *.sou file (mine is now 732KB) is binary and alas cannot be edited as you describe.

I went to the link you posted and gleaned a few ideas.  What "worked" was the following:

• I loaded the *.SLN and went to Tools | Import & Export Settings | Reset all settings (choosing the backup option to write out the old settings).

• I closed VS2010 and deleted the *.sou file.

When *,SLN was relaunched, the Source Files loaded into the main editing pain automatically and I noted that the new *.sou file was a scant 13KB.


All my hard-fought dashboard customizations are LOST !!!!  BooHoo!

This "slippage" has to be a serious problem with VS.  Given what I know now, I'd rather go back to what I had and simply reload my source files one at a time each session, as PITA as that is.  At least then I'd keep my customizations.

And yes, I forgot to mention - another symptom was that my solution space has been taking F-O-R-E-V-E-R to load (slower with each passing month).  This is consistent w/ app4619's remarks.  For the  longest time, I had been wondering what was up w/ this.   Now we know it's coupled with the failure-to-automatically-load problem ...

There has to be a robust fix for this.

I don't think this is a fortran issue it is a VS issue that can occur whatever language is being used. It has not struck me for a while. 

I did not edit the suo file I edited the vs setting file which is used to re-create the suo. The reset blows away the vs settings file with a new one


Also when you have the settings you want you can make a backup copy of the vs settings text file to use when/if  you next have a problem..

I completely agree that it's not a Fortran issue (never implied that it was).  In fact, I emphasized VS in my notes.

Sorry if I misunderstood about editing the *.sou file.  Do you have a name for the editible "VS settings file"?

As others have noted, the hidden .sou file is where VS remembers things such as which files were open when you last closed VS, debugger breakpoints, etc. It is not user-editable - it's a binary file. If it becomes corrupted, then deleting it is really the only thing you can do.

Steve - Intel Developer Support

From memory I think  I did something like::

exported the settings.

closed vs and deleted the suo file

edit the exported file  to get rid of a zillion repeated bookmarks

Open Vs and import the edited settings (there my have been a blow away existing settings (reset) before that last step

I can't be certain it was a year or so back.....




Leave a Comment

Please sign in to add a comment. Not a member? Join today