Source control

Source control

Hello, all,

I would like some help and/or advice about source control.

Is anyone using Team Foundation Server 2010?

If so, have you tried using Visual Studio 2013?

I have fortran projects that have been in development, successfully, using Visual Studio 2010 and TFS 2010.

Now, however, I have added a workstation using Visual Studio 2013 and am seeing a message when the solution is opened.

The message says that the project is not bound to source control.

If anyone has seen this message, I would very much appreciate dialog with you.



8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

We're having this issue too:
Microsoft Visual Studio Premium 2013, Version 12.0.21005.1 REL
Team Foundation Server 2010
Intel(R) Visual Fortran Composer XE 2013 SP1 Update 1 Integration for Microsoft Visual Studio* 2013, 14.0.0074.12

Unortuantely We have not figured out what we need to do to correct it. Getting the dialog box with message

"The project file <.vfproj name> is not bound to source control, but the solution contains source control binding information for it." 

for every Fortran project in the solution is a less-than-ideal experience. In fact it freaks people out because they are not sure which option to choose ("Use source control binding" or "Remove binding").

This issue is easy to reproduce:
1. Create a new Intel(R) Visual Fortran Static Library project
2. In the solution exporer, right click the new solution file and choose "Add Solution to Source Control..."
3. Check in the newly added solution and project files to source control
4. Close the solution
5. Re-open the solution
6. Observe the message "The project file <.vfproj name> is not bound to source control..."

I have tried unbinding/binding the project files using the File > Source Control > Advanced > Change Source Control... tool. This did not solve the issue.

I have tried unloading the project files and modifying the project's <VisualStudioProject> tag's source control items from correct binding information to the following:


This also did not solve the issue.

It'd be great is someone could point us in the right direction for solving this issue! 


Thanks for your reply, Nathan.

I posted a few threads on the msdn forums, TFS and Visual Studio, but so far no resolution.

... will post here if I find any useful info.



I have escalated this to the developers. The issue ID is DPD200250749.

Retired 12/31/2016

Hello Steve,

Have the developers been able to make any progress on this?  We are experiencing the same problem and the only resolution seems to be to remove the binding ... but of course we don't want to do that.



I have not heard from the developers on this - I will ping them.

Retired 12/31/2016

This problem has been fixed - the fix is planned to appear in Update 3, scheduled for late April. The developers provided me with a fixed copy of the affected DLL which you can try. Extract VfProj.dll from the attached ZIP and put it in the C:\Program Files (x86)\Microsoft Visual Studio 12.0\Intel Fortran\VFPackages folder. This is for VS2013. I have asked the developers if this DLL will also work for VS2012, or if a different one is needed If so, I'll get that.

Let me know how this works for you.


Downloadapplication/zip U496351.zip598.61 KB
Retired 12/31/2016

I just tested the fix and it works!  I appreciate the following through on this.



Leave a Comment

Please sign in to add a comment. Not a member? Join today