strange error in Locals window

strange error in Locals window

I may have broken either Visual Studio or my fortran code. In the debugger, the Locals window is showing
CXX0033: Error: error in OMF type information
for fixed size arrays in a locally defined data structure

This code was running fine. This problem just started yesterday.
Anyone know what the problem might be?

54 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

This might be a problem with the type information for your structure in the pdb file, especially if you made any changes to your structure. Perhaps if you delete and recreate the pdb file when you rebuild?

Thanks for the suggestion.  I tried it, but it didn't seem to make any difference.  I still get the same error about OMF type.  I have not knowingly changed anything involving the types.  Is it possible I messed up something else, and memory is getting clobbered?

Does your code actually fail, e.g. if you run it without debugging, or is this just a debugging problem when you try to look at local variables?

Array bounds checking and traceback should be on by default in a debug build. You could turn on interface checking at compile time (Fortran/Diagnostics/Check Routine Interfaces) just in case. It's unclear, though, why these sorts of errors would lead to CXX0033.

I changed Fortran/Run time/run time error checking from None t All, but this didn't make any difference, and didn't turn up any noew errors.

The code will run outside the debugger, but produces garbage.  Lots of NaN.

I have no idea what the error message means.  Do you know what "OMF type information" is?

Just a suggestion but perhaps copy the sources to a clean folder and make a new solution and project from scratch perhaps? I spent a long time trying to find a problem recently and this worked,..... Something is maybe screwed up (corrupt) ....

I googled your fail (what did we do before google?)

Anyway, the hits all showed an old Microsoft C/C++ bug with debug information for precompiled headers.

Now, .mod files are very similar in some aspects to precompiled headers, so it's possible that something happened while building one or more of your .mod files, that dropped invalid data into your .pdb file.

I know you said you deleted the .pdb file and rebuilt, but can try doing a more extensive clean with a full rebuild?  Use Windows Explorer or a command window to confirm that all .obj, .pdb, .mod files are removed before starting the rebuild.  There are two pdb files created, please make sure both of them are gone.

If all else fails, you can shut off pdb file creation, and use the /Z7 command line switch.  I don't see a property page item that corresponds directly to /Z7 (which means C7-compatible) so you will have to use the "Command Line" page and add it manually.

     I hope this helps -


I tried build, rebuild, clean, deleting the pdf files, etc., but none of these made any difference whatsoever.

To rebuild the sln from scratch will take some doing, but I guess that's all that's left.  I did not create it, and it has a dozen subprojects in it.  Sometimes ya just gotta hate computers.



Given that there's a CXX error showing, I wonder if the Fortran debug support is loading. Can you try a new, simple Fortran project and see if the Locals window looks right? Look for Fortran datatypes and not C types in the display.

Steve - Intel Developer Support

Something seems to be messed up.

From the Samples collection I loaded matrix_vector_multiplication_f.sln

I set a breakpoint on the first line which is   a = reshape(...)

Press F5, and it stops on this line.

In the locals window, arrays B and C are there, but A is not.  I don't see any reason why A should not be there.

Should I remove and reinstall Visual Studio 2012?


The matrix vector sample contains these three lines
real, dimension(TOTROW,COL) :: a
real, dimension(COL) :: b
real, dimension(TOTROW) :: c

If I put the "a" line after the "b" line, then only "c" appears in the Locals window.
If I put the "a" line after the "c" line, the no arrays appear in the Locals window.
Is this supposed to happen?

I doubt a reinstall will help. Please give us a test case we can look at.

Steve - Intel Developer Support

I don't see any of this behavior. I just opened the sample solution, which got converted for VS2012. I compiled the debug Win32 version and the debugger worked as expected. In the Locals window, data types were REAL(4) for A,B,C, REAL(8) for CPTIM1,CPTIM2, INTEGER(4) for I,J,SIZE1, SIZE2. What data types do you see? (Steve's question).

Now we're getting somewhere.
The "Type" that is given for arrays B and C is float[101]
The "Type" given for scalers CPTIM1 and CPTIM2 is double

If reinstalling VS2012 won't help, is there a quick way to get it to reset all application settings, and perhaps reregister itself in the registry?

I forgot to say that variables I, J, SUM, SIZE1 and SIZE2 do not appear in the Locals window.

My VS2012 did the "upgrade" of the sample project without any complaints. I did not change anything in any of the project settings. The "Configuration" is "Active(Debug)" and the "Platform" is "Active(Win32)"

It's beyond me why the debugger is showing "C" data types in the Locals windows.

Try uninstalling and reinstalling Fortran.

Steve - Intel Developer Support

Steve. I will use Control Panel to uninstall
Intel Composer XE 2013 Update 4 for Windows
and also
Intel Inspector XE 2013 Update 6
These are the only Intel items in the list.
Also in the list is
IMSL Fortran Library 6.0 for Intel(R) Visual Fortran Composer XE 2013
I am using that, and I will leave that one.
After that I will install IVF from a huge download file named

Inspector is uninstalled.

Fortran is now being uninstalled.  That will take a while.  The "repair" option was not available because it said it did not detect installation media.

Is there anything I should wipe out before reinstalling?




I would delete the "Intel Fortran" folder under the Program Files (x86)\Microsoft Visual Studio 11.0 folder.

Steve - Intel Developer Support

The Visual Studio 11.0 folder does not contain an Intel Fortran folder, but Visual Studio 10.0 does and it contain 216 mb of mostly library files. I will move that folder out, and reinstall Intel Fortran.

Visual Studio 10.0 is for VS2010. If you also have that installed, don't touch it.

Steve - Intel Developer Support

I had moved the Intel Fortran folder out of VS2010 and onto the desktop. Intel Fortran Composer is installing right now, but it seems to be stuck on "step 13 of 25" which is installing VS 2010 Shell. It's been installing now for over an hour. Pretty soon I'm going to kill it and start over.


I killed the installer and ran it again.  This time it asked me "modify, repair, remove" to I picked repair.  It finished that in about a minute, but when I load my fortran project it says "incompatible".  I need to start over.

You said you were using VS2012 - you should not need the shell. Did you uninstall VS2012? Or did you really mean VS2010?

At this point I suggest uninstalling Fortran, uninstalling all Visual Studios, delete any Visual Studio folders, then starting over.

Steve - Intel Developer Support

I am using VS2012.  I did not do anything to either VS2010 or 12, other than moving the Intel Fortran folder out of the VS2010 folder.  This was done after running the uninstaller for IVF.

Right now I an running the uninstaller for VS2012.  That will take a really long time based on prior experience.  Right now the VS2012 un-installer is creating a system restore point, and that alone will take the better part of an hour.  When this finishes, I will run the uninstaller for VS2010.

When I go to reinstall everything, what order should I do what?  I will plan on doing VS2012 first, then Intel Fortran.  Hopefully IMSL will survive all this.

Yes, that order is correct. IMSL will be unaffected.

Steve - Intel Developer Support

Upon attempting to install VS2012, I get this message

Microsoft Visual Studio 2010 Tools for Office Runtime (x64) Package Failed

Is this important?  I haven't tried to install IVF yet, but I plan to tomorrow.





No, that isn't important.

Steve - Intel Developer Support

I have installed VS2012 and Intel Fortran.  I'm trying to run the matrix_vector_multiplication.sln sample project.  It will not build.  I get an error that says:

Configuration 'Debug/Win32" requires compiler support for the Win32 platform, but that support is not installed.

This is an entirely new problem.  I got a similar error when I picked Win64.  What do I do?

What is the filename of the EXE you used for the install? Did you use the default location for the install?

Steve - Intel Developer Support

The name of the file I ran is setup.exe that came from w_fcompxe_2013.4.190.exe.  I took the defaults for everything.

Intel Fortan was not in the Add Remove Programs applet.  So I just now ran the IVF setup.exe again, and this time it finished without freezing.  The matrix_vector sample project will now build and run.  That's the good news.  The bad news is that after the better part of two days uninstalling and reinstalling everything, it didn't do any good.  In the Locals window I'm still seeing float[] and double instead of REAL, and matrix A and some other variables do not appear.

I really don't know what to do.  Should I give up on this computer and go get another?


Could I convince you to uninstall Fortran (only) and download and install Composer XE SP1 Update 1? (w_fcompxe_2013_sp1.1.139.exe)

Something is preventing the Fortran debug support from loading. Do you see the same behavior for a newly created Fortran Console project?

Steve - Intel Developer Support

I'll try anything.  How do I get that download?  The Intel Software Manager will only tell me that I've got the "latest software available installed".

I created a new console project from scratch and added the two source files for the matrix vector multiplication sample.  I got exactly the same behavior in the debugger as with the original sln project.

Tomorrow I may go looking for another computer.  If I get one, I will do a full install of VS2012 followed by a full install of Intel Fortran Composer.



It could be that your license support does not allow a newer version.

Do you have ForDbgEE.dll and ForDbgSW.dll in C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\Packages\Debugger\ ?

Steve - Intel Developer Support

Those two files are there and have dates of 1/16/2013



I'm having difficulty understanding what could cause this. I will probably have to ask the developers for some suggestions. Not that I think it will help, but please follow the various troubleshooting steps in

It would also be interesting if you install on another PC and see what it does.

Steve - Intel Developer Support

In case this helps, the following is from doing "copy info" in the About Visual Studio box.
How does one identify the exact version of intel fortran that is installed?
Is the one I have 13.0.3624.11 ??


Microsoft Visual Studio Professional 2012
Version 11.0.50727.1 RTMREL
Microsoft .NET Framework
Version 4.5.50938

Installed Version: Professional

LightSwitch for Visual Studio 2012 04938-004-0034007-02586
Microsoft LightSwitch for Visual Studio 2012

Office Developer Tools 04938-004-0034007-02586
Microsoft Office Developer Tools

Team Explorer for Visual Studio 2012 04938-004-0034007-02586
Microsoft Team Explorer for Visual Studio 2012

Visual Basic 2012 04938-004-0034007-02586
Microsoft Visual Basic 2012

Visual C# 2012 04938-004-0034007-02586
Microsoft Visual C# 2012

Visual C++ 2012 04938-004-0034007-02586
Microsoft Visual C++ 2012

Visual F# 2012 04938-004-0034007-02586
Microsoft Visual F# 2012

Visual Studio 2012 Code Analysis Spell Checker 04938-004-0034007-02586
Microsoft® Visual Studio® 2012 Code Analysis Spell Checker

Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

Visual Studio 2012 SharePoint Developer Tools 04938-004-0034007-02586
Microsoft Visual Studio 2012 SharePoint Developer Tools

Intel(R) Visual Fortran Package ID: w_fcompxe_2013.4.190
Intel(R) Visual Fortran Composer XE 2013 Update 4 Integration for Microsoft Visual Studio* 2012, 13.0.3624.11, Copyright (C) 2002-2013 Intel Corporation
* Other names and brands may be claimed as the property of others.

NuGet Package Manager 2.0.30625.9003
NuGet Package Manager in Visual Studio. For more information about NuGet, visit

PreEmptive Analytics Visualizer 1.0
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

Web Developer Tools 1.0.30710.0
Microsoft Web Developer Tools contains the following components:
Page Inspector: Tool that offers an efficient way to decompose Web Applications and diagnose front-end issues.
Web Publishing: Extensions required for Web Publishing for both hosted servers as well as on premises.
Web Form Templates: Includes the default templates for Web Form Applications.
Editor Extensions: Includes HTML, CSS, and JS editor extensions that greatly enhance the development experience.

It's the "Package ID", w_fcompxe_2013.4.190, that identifies the product version. This says you have Composer XE 2013 Update 4, build 190.

The "13.0.3624.11" is the version of the specific integration into Visual Studio you are using - it isn't directly convertable to a product version, though the 13.0 gives an approximation. The .11 at the end indicates the VS version for this integration, VS2012 (Visual Studio 11.0).

Steve - Intel Developer Support

I went to that troubleshooting link. Here is something that looks relevant:

VS2013: C:\Program Files (x86)\Microsoft Visual Studio 12.0\Intel Fortran\VFPackages

Check to see if this folder contains six DLL files Windows may hide the file type for DLL files - the file names are
VFFortSvc.dll, I do not have this one
VFToolOpt.dll. I do not have this one
If any of these files are not present, uninstall and reinstall Intel Visual Fortran.

So I'm going to (again) uninstall and reinstall Visual Fortran, then look for these files.


You missed important text:

NOTE: If you have Intel Visual Fortran Composer XE 2011 Update 6 or later, (compiler version 12.1), or Intel Visual Fortran Composer XE 2013 (or later), and are using VS2010 or newer, there will be only four DLLs: VFAVwin.dll, VFHieEditor.dll, VFProj.dll and VFProjConvert.dll.


Steve - Intel Developer Support

Too late, fortran is now uninstalled.
I will uninstall VS2012 again, then use CC cleaner to clean the registry, and start over.

Please delete the Microsoft Visual Studio 11.0 directory before reinstalling.

Steve - Intel Developer Support

Will do.
That folder contained only a folder named Common7. Inside there, there are 226 files, abouit 8 mb.

Good. Delete all of it.

Steve - Intel Developer Support

VS 2012 has be reinstalled. As before it said "not all features could be installed"
Microsoft Visual Studio 2010 Tools for Office Runtime (x64) Package Failed

Next up is to install Intel Fortran from w_fcompxe_2013.4.190

Fortran is installing now. This is what the installer said it was going to do:

Destination Folder(s)
C:\Program Files (x86)\Intel\Composer XE 2013\

Components to Install
Intel Visual Fortran Compiler XE
Intel Visual Fortran Compiler XE on IA-32
Intel Visual Fortran Compiler XE on Intel(R) 64

Intel Math Kernel Library
Intel MKL on IA-32
Intel MKL on Intel(R) 64

Integration(s) in Microsoft Visual Studio*
Visual Fortran Integration(s) in Microsoft Visual Studio*

Configuration Options
Integration with Microsoft* Visual Studio* 2012 software

Well, that's done. It made no difference. I loaded the sample project again
C:\.....\Documents\Visual Studio 2012\Fortran\vec_samples\matrix_vector_multiplication_f.sln
I did a Rebuild, set a breakpoint, and ran it. Look at the screen dumps in the doc3.docx file attached to this post. The Locals and Watch windows have problems.



Downloadapplication/vnd.openxmlformats-officedocument.wordprocessingml.document Doc3_1.docx73.45 KB

The Fortran debug support is not loading. I will have to ask the developers for suggestions as to what to try next.

Steve - Intel Developer Support

Please do that.  Meanwhile I am trying to get another computer to install VS2012 and IVF.



Perhaps this is it: make sure that the VS setting Tools > Options > Debugging > Edit and Continue > Enable Native Edit and Continue is off. If this is on, it will have exactly the effect you describe. See screenshot attached.




Downloadimage/png U499256.png25.94 KB
Steve - Intel Developer Support


Leave a Comment

Please sign in to add a comment. Not a member? Join today