error #7002: Error in opening the compiled module file

error #7002: Error in opening the compiled module file

I have a Visual Studio 2008 project where some of the fortran files 'use' a module containing interface definitions. When I rebuild the project, I get the following error at the point where the USE statement is:

error #7002: Error in opening the compiled module file Check INCLUDE paths

However, if I compile the module files first (right click then compile), and then build the project (not a rebuild) I do not get the error. The module files are definitely included in the project. Its almost as if there something wrong with the build order but I dont think I can change that.

Any ideas?

For info, I am using Intel FORTRAN compiler 11.0.075

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Something is causing the build order dependency analyzer to make a mistake. You're using a rather old version, and we've fixed some bugs in that area since 11.0. One issue I know of with older compilers is if you use the:


syntax with the :: - the dependency analyzer doesn't understand that. You can also run into problems if you have circular dependencies.

Retired 12/31/2016

Normally when I get such issues I do a clean and the a build. If that fails I have often found it is because there are some circular dependencies so there no correct build order...

Thanks Steve and app4619.

I don't have the colons in the USE statement. None of the modules which are USE'd are USEing any other modules or files so I don't think I have a circular dependency. I tried a clean but I still get the problem.

Is there a way to tell if I have circular dependencies from the project file?

No, there isn't.

Retired 12/31/2016


For info, I don't think its a compiler issue. I have other similar projects in the same solution which use many of the same files (including the one that complains) but they build without any problem. The project settings appear to be the same but there must be something I am missing somewhere.



I have just exited Visual Studio, then restarted it and now it appears to be OK. Not sure why but maybe one of the many changes I made in an attempt to find the problem has just taken effect?

Leave a Comment

Please sign in to add a comment. Not a member? Join today