Debugger Not Working

Debugger Not Working

I recently recently received a new Corporate PC with Windows 7 (I know, it's old). Since the old Compaq VF won't work on W7 we installed Intel Composer XE 2013 with Visual Studio 2012. My problem is that even though a program compiles and runs, I can't debug it.

When I set a breakpoint, the debugger will stop there but I can't see the value of any variables. For every variable I list in the watch window, I get the error message "unable to evaluate the expression". It appears that either the debugging information wasn't saved, or the debugger can't find it. The project configuration IS set to debug:full and the debug information set to the same. I am compiling 32 bit code on a 64 bit machine, but that wasn't a problem with the Compaq compiler.

I've tried this with my own codes that worked fine under CVF 6.6 and I have compiled the Calendar sample that came with Composer XE 2013 and the same thing happens.

This was installed over a network so there may be linkage/license issues.

Before I go postal with our IT department, what else should I look at?

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

It sounds like the fortran integrations for VS are not installed properly. I think you will find some recent threads that will help on this if you do a search.

 

I suggest uninstalling and reinstalling Fortran. This usually corrects the problem you're seeing. It isn't VS integrations, per se, but debugger integrations (yes, I know the debugger is part of VS...)

Retired 12/31/2016

Thanks, Steve. We'll do that.

Are there any choices/options we need to be avoid during the install? I'm sure IT just clicked setup and let it run. I WILL be present when they reinstall it.

Not that I can think of.

Retired 12/31/2016

Leave a Comment

Please sign in to add a comment. Not a member? Join today