How do I specify DLL directories in Visual Studio / Intel Fortran?

How do I specify DLL directories in Visual Studio / Intel Fortran?

I have a project which creates an EXE which links in export libraries for separately built DLLs.  When I debug this EXE it needs to know where the DLLs are located.

At the moment I have to add the DLL directory to the path before I start Visual Studio or copy the DLLs into my Working directory, neither of which option I like.

Is it possible to set the DLL directory in the Intel Fortran project file, so I can use them where they are built without copying them locally?  I see VC++ has this functionality, but I can't see it with Intel Visual Fortran.

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Where do you see this option in Visual C++? Are you referring to the Debugging > Environment property? You can do exactly the same thing in a Fortran project - set that property to:


Retired 12/31/2016

Steve, just below Debugging in the project properties page, see below.  I didn't know how to use the Debugging > Environment property.  But I tried what you say and it works thanks.

I don't think those C++ options don't do what you're asking for, but I'm not sure. They specify the environment for build tools, and Intel Fortran has similar options under Tools > Options > Intel Composer XE > Visual Fortran > Compilers. They don't affect the environment when executing programs.

That said, it's interesting that Microsoft has added project-specific properties for these. I will ask our IDE team to look at it and see if it makes sense to do something similar for Fortran.

Retired 12/31/2016

OK thanks Steve.  I'm not sure what C++ those options are for either, I just thought they might be what I want.

If you look at the description on the property page for Executable Directories, it says, "Path to use when searching for executables while building a VC++ project." As I wrote above, this doesn't affect the application execution environment.

Retired 12/31/2016

Leave a Comment

Please sign in to add a comment. Not a member? Join today