dll error

dll error


I am converting a program from Microsoft fortran power station to intel fortran. I compiled the program and bulid a exe file. when i run the exe file, it give system error " The program can't start because mkl_intel_thread.dll is missing from your computer. Try reinstalling the program to fix the program".

I have added the libraries "mkl_intel_c.lib mkl_core.lib mkl_intel_thread.lib" in the additional dependencies. But still error msg appears.

Any solution for this problem?

Thanks in advance.



3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


You can refer to some previous discussions on "MKL redistribution":



According to your description, it would seem that you didn't encounter a difficulty until you tried to execute, but if you had run within your build environment, your PATH setting should have included the MKL .dll folder which was used for build and link.

If your project conversion includes /iface:cvf (so as to allow use of a .lib or .obj which hasn't been rebuilt) it should be worth while to remove the iface setting for compatibility with normal MKL, Then you could start with one of the /Qmkl options rather than specifying specific libraries, and you might avoid the question of whether you want 32- or 64-bit mode.  In case that cvf option is set, you would have a chance to use MKL only in CVF compatible 32-bit mode.


Leave a Comment

Please sign in to add a comment. Not a member? Join today