ifort error #10037 could not find 'link'

ifort error #10037 could not find 'link'

Hi everyone,

i've installed intel Parallel Studio XE 2013 last 4 months with the combination with MS Visual Studio 2010. It was working perfect till last week when I faced a compiling error by Matlab -Simulink saying "Ansi_C can not be found in registry". After that i've installed Microsoft windows SDK 7.1 and another C++ compiler. After all these changes i couldnt remove the error by Matlab-Simulink and worse than that i am receiving the error: ifort  #10037 could not find 'link'  by Fortran when i try to compile in Intel 64 visual studio 2010 mode.

I have tested almost all suggested solutions here but still having the problem!

Any new suggestion would be appreciated!


7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Perhaps you could look at the paths in MSVS under  tools\options\Intel Composer XE\Visual Fortran\Compilers\Executables ? (Click on '...')

What I see (for intel64) in a vanilla installation is:


The VCInstallDir bin directories should contain link.exe.  Don't know how the other software that you installed might have modified this?

Also check that \Windows\System32\ appears in PATH so that VS X64 can initialize.  Normally set up in control panel > system > advanced system settings >environment variables  (changes take effect after restart).  You can search web for details about this feature of VS X64 .

@Martyn: it is same as yours in my case...still no changes

@Tim: can u please explain more? what I exactly change? what for should i search exactly in web?

the other point I have noticed is that recently i have 3 Microsoft VS folders: 

Microsoft Visual Studio 10.0

Microsoft Visual Studio 11.0

Microsoft Visual Studio 12.0

Can it be some how confusing while pathing through the VC-Folders?

okk i have solved the problem by running vcvarsall.bat in command prompt....but now facing another error:

LNK1112: module machine type 'x86' conflicts with target type 'x64'

now any suggestion??

and now the problem is totally solved by running vcvarsall x64 in command prompt...tnx everyone

Leave a Comment

Please sign in to add a comment. Not a member? Join today