failure during conversion to COFF

failure during conversion to COFF

I am getting a "fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt"

Can you suggest how I can proceed.


10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The message is pretty much self-explanatory. Can you identify which file it is complaining about? Is it one you can recreate? I've seen this years ago when a user tried to link in an old 16-bit library, or one created by an incompatible compiler.

Retired 12/31/2016

The file just says LINK - so it is not one file, it is caused during the LINK.

I have compiled the program many times before without any problem.

Last week a problem was found on my computer that it wasn't installing windows updates - this has been fixed and several windows updates have now been installed. I wonder if this is causing the problem.


Ah, yes indeed! Are you running VS2010 without its SP1? If so, install VS2010 SP1.

Retired 12/31/2016

I'm running Visual Studio 2010

Version 10.0.40219.1 SP1Rel


12 months ago, my computer stopped installing windows updates : After lots of re-installing the O/S, I ran chkdsk and found a disk error ! It could be worth a check.


Thanks John.

I ran chkdsk but still get the same problem. 

I have found this post:

It suggests:

Just overwrite $VCDIR/bin/amd64/cvtres.exe in VS2010 dir with C:/Windows/Microsoft.NET/Framework64/v4.0.30319/cvtres.exe and overwrite $VCDIR/bin/cvtres.exe in VS2010 dir with C:/Windows/Microsoft.NET/Framework/v4.0.30319/cvtres.exe.

Do you think this is the solution? I will give it a try.


It might help. cvtres.exe is the culprit. But this is supposed to be fixed by VS2010SP1.

Retired 12/31/2016

Copying those files fixed the problem - thanks.

Leave a Comment

Please sign in to add a comment. Not a member? Join today