Experience with Winteracter and IVF XE2017???

Experience with Winteracter and IVF XE2017???

Is anyone using Winteracter with XE2017 from within VS to build 32bit applications under 64bit Windows?

When I switch compiler from XE2016 to XE2017, I get an ICE.  Winteracter say that this is due to VS not building from bin\intel64_ia32 but is using bin\ia32, suggesting that the VS Integration for XE2017 is incorrect.  [Winteracter also provide no support for VS usage]

My solution is too big to attempt creating a small test case - Premier Support are reviewing this - I just wondered whether anyone has had any success with this combination?

Thanks

David

12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I found this topic on their web site:

http://www.winteracter.com/newsif17.htm

Generally I found their support was excellent last time I used them.

It should be using bin\Intel64 for building on x64 (even for a 32-bit target). What is the list under Tools > Options > Intel Compilers and Tools > Visual Fortran > Compilers > Win32 > Executables? An ICE is clearly not a reasonable response, no matter what. What's the IPS issue number?

Retired 12/31/2016

Andrew, I agree with you about Winteracter's support.  However, VS integration is not supported by them, only the use of their own IDE.

Steve, the issue number is 6000163143.

Here is Winteracter's full response to my query:

10.10d is compatible with XE2017, when used with the correct compiler.

Here's the answer I gave to another customer recently with the same question:

 =================================

Intel Fortran 17.0 ships in multiple configurations, including:

 

(1) 32-bit compiler for use on 32-bit Windows platforms (installed in bin\IA32)

(2) 32-bit compiler for use on 64-bit Windows platforms (installed in bin\intel64_ia32)

(3) 64-bit compiler for use on 64-bit Windows platforms (installed in bin\intel64)

 

The errors you show are consistent with using (1), but on a 64-bit platform. WiDE 10.10d has been amended to use the compiler in the intel64_ia32 when a 32-bit target and 64-bit host are selected. When this compiler is used, compilation proceeds normally.

 

This can also be verified at a command prompt. Running Intel's environment configuration batch file for 32-bit targets ("compilervars ia32"), adds bin\intel64_ia32 to the PATH environment variable, on 64-bit Windows. Winteracter-based programs compile correctly at such a command prompt, after running that batch file.

 

It therefore looks like Intel's VS integration is using the compiler in the bin\IA32 directory, in your case. I don't know why or how to fix this. Unfortunately, VS configuration issues are outside the scope of our support service.

Steve,

My Compiler settings are:

Executables:

$(IFortInstallDir)bin\ia32
$(VSInstallDir)Common7\IDE
$(VCInstallDir)BIN
$(VSInstallDir)Common7\Tools
$(VSInstallDir)Common7\Tools\bin
$(FrameworkDir)$(FrameworkVersion)
$(WindowsSdkDir)bin\x86
$(PATH)

Includes:

$(IFortInstallDir)compiler\include
$(IFortInstallDir)compiler\include\ia32
$(IFortInstallDir)mkl\include
$(VCInstallDir)atlmfc\include
$(VCInstallDir)include
$(WindowsSdkDir)include\um
$(WindowsSdkDir)include\shared
$(FrameworkSDKDir)include
C:\open\kwc54dw\Dev\Modules
C:\open\kwc54dw\Dev\Winyldmd\trunk\ymdphys\$(Platform)\$(ConfigurationName)
C:\open\kwc54dw\Dev\Winyldmd\trunk\ymd_modules\$(Platform)\$(ConfigurationName)
C:\open\kwc54dw\Dev\Winyldmd\trunk\ymd_commands\$(Platform)\$(ConfigurationName)
C:\Open\kwc54dw\wint\lib.if8
C:\Open\kwc54dw\wint\include
C:\Open\kwc54dw\Dev\Winyldmd\trunk\Yieldmod_wint\$(ConfigurationName)

Libraries:

$(IFortInstallDir)compiler\lib\ia32
$(IFortInstallDir)mkl\lib\ia32
$(VCInstallDir)atlmfc\lib
$(VCInstallDir)lib
$(WindowsSdkDir)lib\winv6.3\um\x86
$(FrameworkSDKDir)lib
C:\Open\kwc54dw\wint\lib.if8

This combination works within the same session in VS when I use 16.0.3.207, but when I switch to 17.0.0.109 or "latest" I get the error.

 

Here is a winteracter demo program, which compiles and runs under XE2016, but fails under XE2017 (doesn't produce ICE like my own project)

Attachments: 

AttachmentSize
Downloadapplication/zip dialog.zip1.72 MB

Do this. On the same Visual Fortran > Compilers page I mentioned above, make sure 17.0 (or Latest) is the selected compiler. Click Reset... In the dialog that comes up, select "Reset settings for selected compiler only" and click Ok.

This ought to change the executable path from \ia32 to \intel64. In version 17, on a 64-bit platform, the \intel64 compiler is used for both targets.

I agree that something went wrong - my home system had the same wrong path, though it didn't cause me any problems. Doing the Reset fixed it.

Retired 12/31/2016

Thanks Steve.

Issue is that v17 uses these folders for Libraries:

$(IFortInstallDir)compiler\lib\ia32_win
$(IFortInstallDir)mkl\lib\ia32_win

While v16 uses

$(IFortInstallDir)compiler\lib\ia32
$(IFortInstallDir)mkl\lib\ia32

This change was not picked up by the VS Integration (possibly because previously the integration install trampled over any extra paths added by users, so this is not part of the install?)

Thanks,

David

On my system, at least, ia32 is a softlink that points to ia32_win. Why do you think the library path is the issue?

Retired 12/31/2016

I made the same experience with Windows 7, IVF2017 and Winteracter 9.20. I suspected problems with the libraries and switched back to IVF2016. I intend to buy the most recent version of Winteracter next year. The new version of Winteracter should solve the problem with IVF2017 (at least I presume that).

rase,

I am using the latest version of Winteracter, and still had problems.  You may light to try XE2017 again, with the path changes that I have given above.

David

David, I hope the discussion here will provoke ISS to make changes in their installation procedure for Winteracter, in order to solve the problems which cause naive user like me such headaches. Thanks for your advice.

Leave a Comment

Please sign in to add a comment. Not a member? Join today