Visual Studio 2017 not yet supported

Visual Studio 2017 not yet supported

On March 7, Microsoft released Visual Studio 2017. Intel Parallel Studio XE does not yet support this - the Intel folks will let you know when it does.

Steve (aka "Doctor Fortran") - Retired from Intel
34 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Support for VS 2017 is targeted for the next Parallel Studio XE 2017 Update 3 release in the May timeframe and the next major Parallel Studio XE release later this year.

This would be a good thread to make "sticky" for a while.

Steve (aka "Doctor Fortran") - Retired from Intel

Is there a workaround or something?  I'm setting up a new build system and I can't wait around till May just because 2017 is not in a search path.

You will need to use a supported version of Visual Studio until support for VS 2017 is available. I don't understand the comment regarding the search path.

The product includes a VS2013-Based build environment. 

Steve (aka "Doctor Fortran") - Retired from Intel

Among the apparent issues for this "upgrade" will be the ability to install VS2017 with C++ support.  After getting the invitation from Microsoft, I just tried it on Win8.1, and it failed at the point of attempting to download the new default Win10 SDK.  Attempting to repeat using the URL to download the SDK by itself appears to confirm access denial.  It seems premature to expect Intel to support customers with these dependencies until such problems are resolved.

The installer doesn't find VS2017 - hence the search path comment.  If you'd like more feedback or details on what I mean, contact me directly.

No, it wouldn't. 

Steve (aka "Doctor Fortran") - Retired from Intel

The installation of VS2017 went smoothly on my old Nehalem under Windows 10/1607 (including the new Win10 SDK).  After finding the hidden 64-bit development cmd shortcut, I was able to build C++ objects and link them successfully under a VS2015/ifort 2017.2 installation.  No apparent difference in execution from VS2015.

So the VS2017 installation seems to have a problem with Win8.1.
 

It's typical for each new VS release to make breaking changes to integration from non-Microsoft languages. There's no workaround - you just have to wait. But VS2015 still works.

Steve (aka "Doctor Fortran") - Retired from Intel

An incident involving a cat and a mug of tea has sent my laptop to the trash can :-(  so I have a good few hours of work ahead to get a new one "fully loaded".

A was using VS Community, but I can only find download links for 2017 which is not supported. So I have a bit of a problem. Using shell is also a  problem because of the lack of resource compiler and the third party one doesn't work with many of my resource files. Is there a well hidden vs2015 community link somewhere? 

A bit convoluted, but try this...

  1. Join Visual Studio Dev Essentials (free) and log in.
  2. Click to accept the terms.
  3. Once you have logged in, click Downloads in the navigation bar
  4. In the search bar, search for "2015 Community". An entry for Visual Studio 2015 Community with Update 3 will appear. Click that and then click the Download button.

 

Steve (aka "Doctor Fortran") - Retired from Intel

Thanks Steve, I went down that road, it looked promising, I can't remember exactly what went with wrong with that but I then gave up as I found a full installer for VS in some backup date so am now up and running.

As for the installation of VS2017 on Win8.1, now it wants to "update visual studio installer."  There has been an update for VS2017 so a new installation is required, even if the initial vs2017 download hasn't changed.  No doubt this requires Intel compiler compatibility testing to start over.

As I reported before for Win10, now on Win8.1 as well it is possible to make .obj in the VS2017 environment and link and run them in the VS2015/ifort2017u2 environment.  The one performance improvement I saw is with the C++ fill() which has come up close to ICL (or ifort) performance.

Start over? No. But there will likely be some "touch testing" to make sure it didn't break something. It's the Visual Studio code itself that is the issue, not the installer.

Steve (aka "Doctor Fortran") - Retired from Intel

Thanks Steve. I also had this problem. If I hadn't found your link to VS2015 I'd have been putting in a support call. 

Have a good retirement ... but please don't stop contributing here!

 

 

I am using VS 2017 with the Beta 2018 Intel Fortran compiler -- it is running my programs with no problems other than a few minutes to fix DISLIN. 

I really enjoyed working with VS 2013 -- it is my preferred IDE but one program I use installed the VS 2015 Shell and then it kept intruding into VS 2013 in annoying ways. The VS Selector gets confused at times. 

A few weeks ago I got a nice note from some kind lady a Intel asking me if I wanted to take part in the 2018 beta test. Being your average Australian redneck (watch Mum being the last words of most Australian men) I said yes and also installed 2017. 

They work well together and my main structures program compiled without a hitch and appears to run nicely. 

2017 is worth the step up. You can even get a hacked version of the Color Theme editor so you can have decent colors. 

Being on the edge can be hassle -- the latest Windows 10 Fast ring has one or two glitches, but what the heck -- mum is always watching over me. 

Steve: Why does the text editor her underline the spelling mistakes but does not offer replacement? 

I also got my Intel NUC running stuff into Azure in the cloud across a CELL Modem -- it was an interesting challenge to get linked to the Azure SQL Server. Some Instruction sets are better than others. 

Steve can I deploy a Intel Fortran program onto the Windows 10 IoT version? 

John

 

 

John, I am not sure which text editor you are referring to.  

As for Windows 10 IoT edition, the key is whether or not "desktop" API applications are supported, as Intel Fortran uses that API. There are three sub-editions:

  • Enterprise - will run Desktop applications, so Intel Fortran applications should work
  • Mobile Enterprise - runs only Universal applications, so no Intel Fortran
  • iOT Core - runs only Universal applications, so no Intel Fortran

Feel free to start a new thread on this if you try it.

Steve (aka "Doctor Fortran") - Retired from Intel

VS 2013 does not work with Windows 10, at least not on my DELL computer.

 

so hopefully they are going to test VS 2017 in that environment ?

 

Probably a lot of users have migrated there so far.

Yes, VS2013 is supported on Windows 10. I use that combination often.  If you have a specific problem, please start a new thread for it. 

Steve (aka "Doctor Fortran") - Retired from Intel

The Intel Parallel Studio XE 2017 Update 4 release is now available with support for Microsoft Visual Studio 2017.

(Note: There was no Update 3 release of Parallel Studio XE 2017 for Windows).

Please start a new forum thread for any issues or questions. Thank you.

Intel Parallel Studio XE 2017 Update 4

Will not install as it can't detect that I have Microsoft Visual Studio 2017 installed and working.

This version of Parallel Studio is supposed to work with VS 2917.

Is there a new forum for this?

 

 

Others have started separate new threads about problems they have experienced. That is preferred.

Others experienced integration or install issues but not a failure to detect VS2017 as I am reading them.

https://software.intel.com/en-us/forums/intel-visual-fortran-compiler-for-windows/topic/734101
https://software.intel.com/en-us/forums/intel-visual-fortran-compiler-for-windows/topic/734035
https://software.intel.com/en-us/forums/intel-visual-fortran-compiler-for-windows/topic/734040

As with others, in starting a new thread please be prepared for our request for your installation logs. You can wait to provide those until our initial reply to provide those via a private reply (via Send Author a Message) if you wish.

Sorry to interrupt the topic, but as a fresh installation, what are the benefits of installing Intel fortran on visual studio 2017 over visual studio 2015?

Should I simply choose visual studio 2015 to avoid the troubles? I could not find any features in Parallel Studio XE 2017 specifically for visual studio 2017 in release notes.

There is no advantage from the Fortran perspective. Many customers want to use the newer VS for other reasons, not the least of which is the free Community edition (since MS no longer makes the 2015 version easily available.) If you already have VS2015, use that, or if the included VS2015-based Fortran environment suffices, use that.

Steve (aka "Doctor Fortran") - Retired from Intel

Further to #26 I would add that recently released versions of VS are normally a world of pain until we have had a few subsequent Fortran updates..

The only issue I have seen with VS2017 is a VS bug that it can't locate the Resource Compiler DLL. This is not Fortran-specific, and Microsoft has acknowledged it. The workaround is simple enough (copy rcdll.dll into the folder named in the VS message.) Otherwise, I find the VS17 "home page" interface to be somewhat annoyingly useless, but it works.

Steve (aka "Doctor Fortran") - Retired from Intel

Quote:

Steve Lionel (Ret.) wrote:
The only issue I have seen with VS2017 is a VS bug that it can't locate the Resource Compiler DLL. This is not Fortran-specific, and Microsoft has acknowledged it. The workaround is simple enough (copy rcdll.dll into the folder named in the VS message.) Otherwise, I find the VS17 "home page" interface to be somewhat annoyingly useless, but it works.

That is good to know and unusual, VS is such a complex product it seems best to me to wait for and update or two for that also.... If you just want to use fortran then there never seems to be anything  that greatly enhances life in newer VS versions. 

There are certain rules in Life.

The most important rule is:

When Intel Fortran does not work - ie one gets an rc.exe not found error check the latest Steve posts,

Oh well -- rule relearnt. 

Italy is wonderful this time of the year.  Everyone over here uses MATLAB and I sort of look on bemused. 

John

So things with VS 2017 and the Intel Beta got interesting with the last upgrades of the Windows Preview.  First the Color theme VSIX stopped working -- then the Beta started to throw interesting problems trying to create a new Fortran job.  I tried uninstalling everything and reinstalling multiple times. 

Finally back with Vs2015 and Intel 2017.  Pity but I cannot waste another day on it.

Something is broken as the Intel Beta installer never finishers on the latest Windows Preview and VS 2017 croaks.

I am aware of the risks, but what the heck - look ma no hands

John

Additional information on VS2017 support is provided in this article:

https://software.intel.com/en-us/articles/intel-software-development-tools-integration-to-vs2017-issue

 

Devorah - Intel® Developer Support

Sorry for commenting here. I did not know where to ask this. I am trying to use ifort from parallel studio.  every time i use IFORT is  echoing the version number and its copyrights. Is there a way to get rid this?

Attachments: 

AttachmentSize
Downloadimage/png Capture2.PNG6.45 KB

Add /nologo to the ifort command line to suppress that output.

Steve (aka "Doctor Fortran") - Retired from Intel

Leave a Comment

Please sign in to add a comment. Not a member? Join today