libifcoremd.dll libmmd.dll Missing Error

libifcoremd.dll libmmd.dll Missing Error

Hello,

I recently installed Parallel Studio XE for Windows and Visual Studio and have had no trouble compiling and executing code. That is until I restarted my computer. Now, code that worked yesterday no longer works apparently due to two missing DLLs. I have found running the Parallel Studio installer again and choosing repair fixes the error until I restart again.

Looking through results here and elsewhere online it seems that often this boils down to a PATH issue. I have checked that my PATH variable contains what I think are the correct links to the DLLs but I still get this error, even after restarting my computer or logging in. I have found that the DLLs exist in a number of different locations for other programs. Some of these are appended to my PATH (mainly for Python) but I don't know if that will have an effect.

Thanks

Alastair

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

There can be two compiler environments, one producing 32-bit EXEs and the other 64-bit EXEs. These use 32- and 64-bit RTL DLLs, which may have the same names, eg., a 32-bit libmmd.dll and a 64-bit libmmd.dll. If the PATH leads to a mismatched version, e.g., your EXE is 64-bit but only the 32-bit DLL is found, you have a problem.

You can investigate the problem by checking that the DLLs found along PATH have the correct bitness, using Dumpbin or by selecting the DLL in the Windows Explorer and checking its properties using a right-click.

Leave a Comment

Please sign in to add a comment. Not a member? Join today