VTune Shows No Data Running Application with MySQL

VTune Shows No Data Running Application with MySQL

Hi,
I tried a C++ program connecting with MySQL and read data from the DB. I compiled such C++ program and ran VTune to launch this application.
VTune completed the analysis right away (within 1 second) and told that the Analysis is Completed Successfully. However, there's no data shows in Bottom up tab. But when I ran the application manually, it took minutes to complete.
I tried to comment the code that connect to MySQL. VTune then worked well.
So it seems there's an error with VTune running with program that connected to MySQL.

How can I fix this please?

Bestregards
summergirl

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The problem was solved. I had messed up the access of the DB for the root user. After granting the access, it works well. Maybe it will be helpful for someone like me who is not familiar with linux and mysql in the future. Best of luck!

Leave a Comment

Please sign in to add a comment. Not a member? Join today