VTune Amplifier XE 2011 cannot run hotspots analysis on Westmere-EX

VTune Amplifier XE 2011 cannot run hotspots analysis on Westmere-EX

I am trying to use VTune Amplifier XE 2011 Update 9 (build 229127) command line tool to profile my application, but it hangs and never seems to capture any data. Profiling using hardware counter based analysis, such as lightweight_hotspots, works perfectly.

The simple failing caseis the following:
amplxe-cl -collect hotspots/bin/ls

When I run this command, it never finishes and I can see using top that ls is running, but amplxe-cl and amplxe-runss are not.
This happens under Red Hat Enterprise Linux Server release 6.2, kernel version 2.6.32-220.17.1.el6.x86_64 on a server with 8 Xeon E7-8867 processors.

Any help would be greatly appreciated.

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi, I am observing the same issue.

I am using an Intel Xeon Processor E7-8870
SLES11 SP1 Kernel x86_64 and gcc version 4.3.4

I have not been able to replicate the behavior yet. What
output if any is displayed after the analysis command is ran? Also, are you running as root? Are you able to run other analysis successfully?

- Rob


When I run the hotspots analysis using "amplxe-cl -collect hotspots /bin/ls", I do not get any output. The same thing happens when I try other user-mode analysis, such as concurrency - I see that ls is running (and using ~98% CPU, but there is no output from either ls or amplxe-cl). I'm running as root.
As for the other analysis, I've managed to successfully run only lightweight_hotspots and two Eagleton specific analyses: wsmex_read_bandwidth and wsmex_write_bandwidth.


Hi folks,
I am not running as root but the user is subscribed to vtune group.

I am able to run following NHM analysis (though i have not validated results jet):
- General Exploration
- Read Bandwidth
- Write Bandwidth
- Memory Access
- Cycles and uOps
- Front End Investigation

From the Algorithm Analysis tab i am only able to run Lightweight_hotspots. The other analysis show the above behavior described from Danica.



Can you clarify if you are able to run hotspots analysis
on other application or just the example provided? This will provide additional scope to the behavior.


Hi Rob!

Unfortunately, like Andres, I am not able to runhotposts (or any other analysis which relies on user-mode sampling) for any application. The behavior is always the same: VTune never manages to attach to the application or it never starts the application (applications looks like it's running but doesn't do any real work).

I have also tried to use beta version of VTune 2013, but it behaves the same way: hotposts analysis never finishes and plain hardware counter based analyses work well. However, if I try to enable call stack collection for lightweight_hotspots analysis, result is either empty or it has information about only one thread in my application which has dozens of threads.

Finally, when I've tried VTune 2013 on another machine which has 4 Nehalem-EX processors (Xeon E7530) and where VTune 2011 works great in all scenarios, I've seen similar behavior of lightweight hotspots analysis: works great without call stacks and produces no results with call stacks knob.

On both machines I use RHEL 6.2 with kernel 2.6.32-220.17.1.el6.x86_64, VTune 2011 Update 9 and VTune 2013 Update 2 and my application is complied with gcc 4.4.3.

Any suggestion on how to get call stack information on the Westmere-EX machine would be greatly appreciated.



After running Hotspots analysis, is a results directory
created at all? If so, can you zip the
results directory and attach to the forum thread (as private if you wish). If any data at all is written in the results
directory, then we may be able to determine when / why the failure occurs.

Additionally, is it possible for you to share the output
of amplxe-feedback.exe which is, by default, located under "C:\Program
Files (x86)\Intel\VTune Amplifier XE 2011\bin32".

Example: amplxe-feedback.exe

If so, zip and attach the data to the forum thread as a
private post.


Leave a Comment

Please sign in to add a comment. Not a member? Join today