Got "Failed to finalize result" in Hotspots analysis

Got "Failed to finalize result" in Hotspots analysis


I just installed VTune Amplifier trial version for Windows. My program is server to handle large number of data analysis requests. I tried to run hotspots analysis to find out performance bottleneck in my program. However, i got "failed to finalize result" after 10 min analysis with "high accurate cpu time" checked. And there's a warning: Cannot load data file `C:\\.....\\r007hotspots-0\\data.0\\2708-2580.0.trace' (Data file is corrupted).
Can someone tell me what might be the reason of data file corruption and finalize result failure?

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


The errors you are receiving have
various causes and we may need additional information about the environment to
properly trouble shoot the behavior.

1. Are you running the latest Intel
VTune Amplifier XE version / update? If
not, please patch to the latest update (update 7).

2. Are you running the analysis as

3. Make sure you have sufficient
permissions to generate result file under the specified directory? Is there
enough disk space in the partition? Can you attempt using another results directory
(-result-dir)? A simple test, specify a
fully qualified path that is a short and simple path where you have full

4. If you disable "high
accurate cpu time", does the behavior change?

If the behavior persists, can you
provides information on the following:

Make sure that you are able to
successfully analyze other applications.
One good test is the Tachyon sample application which comes with the
product. This provides a good baseline
of what is and is not working.

Can you provide information about
the OS, Intel VTune Amplifier XE version / update level you are running?

Can you let me know the command line being ran? From within the Amplifier GUI, you can click
the Get command Line button and copy / paste the command line into the case

How is your application launched?

Are you using Intel VTune
Amplifier XE integration with Microsoft* Visual Studio or Amplifier stand-alone


Thanks Rob. Here is my answer:
1. Amplifier XE version: i download 30-day trial version from offical site.
2. yes I'm running with administrative privilege, and btw will Amplifier XE warn user if he doesn't have privilege?
3. disk space is sufficient, more than 20G free.
4. if disabling "high accurate cpu time", i can finalize hotspots analysis. And i wonder how much "inaccurate" it would bring in?
I run Amplifier stand-alone GUI and attach my program process as target.


Thank you for the additional information. There may be something in the application being
analyzed or another process on the system that is interfering with collection
using the collect highly accurate CPU time functionality. Along with Admin privileges, Intel VTune
Amplifier XE needs exclusive use of OS event tracing. If another Intel VTune Amplifier XE session
or another tool is using OS tracing, then this may be the problem.

The article titled Is
'Collect Highly Accurate CPU Time' Option Required?
discusses important
points about this functionality and how it leverages the OS and Event Tracing
for Windows. It also discusses variables
if this option is or is not enabled as well as trade-offs.

When attaching to process and using the collect highly accurate CPU
time functionality, you may need to run the application to be analyzed and also
Intel VTune Amplifier XE in the same environment. For example, start the application in a
console window and from within the same console window run Hotspots analysis.

Intel VTune Amplifier XE should
warn on certain conditions. The document
about Accurate CPU Time Collection
provides specific details.

For the benefit of folks reading
this thread who may not be aware of this functionality, some background information
about the Collect Highly Accurate CPU Time data functionality can be found in
the on-line help here.

Let us know what happens.

- Rob

Leave a Comment

Please sign in to add a comment. Not a member? Join today