Can run lightweight hotspots, can't run proper hotspots (on tutorial)

Can run lightweight hotspots, can't run proper hotspots (on tutorial)


The title says it all really. Lightweight hotspots and Core2 general exploration work fine. Hotspots, however, doesn't work either on the tachyon tutorial or on my own code. VTune reports that the analysis completes successfully, but the result is empty. Meanwhile the sample program never runs (the program window doesn't appear, etc).

I'm on an administered windows xp install (though have admin privilage) if that has a bearing on anything. VTune Amp XE I installed myself.

Can anyone help? Thanks!

18 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I want to know if application tachyon can work without using VTune Amplifier XE? Are you using latest Update 5?

I can't repeat this prpblem.Please see my steps:
1. Build "tachyon" sloution
2. Open cmd, and go to find_hotspots_Win32_Debug
3. Test application in command line
4. Run amplxe-vars.batto set environment
5. Run amplxe-cl for hotspots analysis => no problem

Regards, Peter

All fine (find_hotspots runs on its own, shows me some pretty balls...) until running amplxe-cl:

C:Program FilesIntelVTune Amplifier XEsamplesenC++tachyon_vtune_amp_xeta
chyonvc8find_hotspots_Win32_Debug>amplxe-cl -collect hotspots -- find_hotspots
.exe ....datballs.dat
Using result path `C:Program FilesIntelVTune Amplifier XEsamplesenC++tach
Executing actions 50 % done
Error: Error 0x4000001e (Cannot load raw collector data)

Have you seen ball displayed when using amplxe-cl?

Is it possible that you can extract example zip to "c:\temp" like directory, then rebuild and run? Or use non-current directory as result directory? For example:
amplxe-cl-collecthotspots-r \temp\r001hs --find_hotspots.exe..\..\dat\balls.dat

Now there is latest version, Update 5 released

Regards, Peter

No, the ball does not display using amplxe-cl, only when running find_hotspots.exe standalone or when using hardware sampling mode. I'm running version 5, same build number as you.

Will have a look at rebuilding and report back.

Saving results in a custom path gives exactly the same error.
Will now look at rebuilding though I did build from fresh to start with so can't imagine much difference...

...and rebuilt in c:\temp as you requested (using vs2008). Exactly the same error, find_hotspots runs fine standalone but amplxe-cl says Error: Error 0x4000001e (Cannot load raw collector data).

It's quite strange - I suggest to submit an issue to, and provide your system info, by running:
amplxe-feedback -create-bug-report

Is it possible that you can do uninstallation / installation of the product, to verify again - before submitting this issue?

Thanks, Peter

You might also look in the data.0 subdirectory of the result directory and see if there are any log or error files present there.

Have uninstalled and reinstalled, no luck, same issue. Will now submit a bug report. Thanks.

Thanks for suggestion; the folder is empty though.

Hi,I'm afraid I have no solution. However I am manifesting exactly the same symptoms as outlind by Crispin - did this ever get resolved?RegardsPaul

This is hard to reproduce it on my side.

My comments are:
1. Copy sample project from "\Program Files (x86)" to your user folder
2. Try to open cmd as "administrator" privilege, and run sample application without VTune, then try hotspots collection.
3. Try latest product which is Update 7.

Regards, Peter

Hi Peter,

I'm afraid that didn't work.

I have administrator privileges on my machine.

I can run the tachyon app standalone.

Having moved the projectI can still run lightweight hotspots from standalone GUI and from within Visual Studio 2010.

If I attempt to run hotspots, the tachyon app does not appear (with lightweight hotspots I see the rendering happen). This occurs within Visual Studio 2010 and with the standalone GUI.

Are there any logs or diagnostics you would like me to attach?



Hi Paul

they never did solve this problem, but hotspots analysis worked fine on my other computer. My best guess is that some peculiarity of the remote administered windows image my employer uses didn't get along with vtune. If you have access to another machine with a standard install this will likely be the quickest workaround.


Hi Crispin,

thanks for taking the time to reply.

I will give that a go - but its all very frustrating - the whole suite seems to work except hotspots - which is exactly why I bought the product!



Help !!, attempting to collect hotspots fails with the following error: 

amplxe-cl -collect hotspots -duration 5 --target-process Orchid.exe
amplxe: Error: ControlTraceW: The instance name passed was not recognized as val
id by a WMI data provider.
amplxe: Using result path `c:\Program Files (x86)\Intel\r005hs'
amplxe: Executing actions 16 % Loading data files
amplxe: Warning: Cannot load data file `c:\Program Files (x86)\Intel\r005hs\data
.0\3824-940.0.trace' (Data file is corrupted).
amplxe: Executing actions 50 % done
amplxe: Error: Error 0x4000001e (Cannot load raw collector data)

I found this issue reported already; but did not see a clear solution. Appreciate any thoughts on how to resovle this issue.

My Runtime Environment:

Intel VTune Amplifier XE 2013. Attempting to collect data using remote agent on my Intel i7 Cpu based target system. Running Windows Embedded Standard 7 OS. 

My two cents are:

1. Install the product on Intel i7 based target system, which is embedded Standard 7 OS.

2. Maybe there were many processes of Orchid.exe, using pid instead of program name may help?

3. In cmd, run amplxe-vars.bat first.

4. Does it work for other process of application? 

5. Specify result directory in "c:\temp\r000hs", if possible.

If you need further assistances, go to submit a ticket with result directory.

Regards, Peter

Leave a Comment

Please sign in to add a comment. Not a member? Join today