Problems installing VTune

Problems installing VTune

I've just tried to install VTune Amplifier XE 2011 on a RHEL5 machine.

I have the following problems:
1) There is no amplxe-gui executable in the bin32 directory (there is in the bin64)

2) Most of the analysis types have a error message:
" Problem accessing the sampling driver. The driver may need to be (re)started. Please refer to the help pages for more information." However I can't find anything in the help pages that describe what to do.

Thanks for any help,

mark

29 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

We have the same problem on CentOS. There was a error message during installation. It seems the samping driver kit is not installed as they did not recongize our linux distribution.

I've tried it on two RHEL5 machines, one of which is the exact kernel version they list as it being qualified on. I see no errors in the installation logs and the driver seems to be installed (that's the sep3_1 driver right?). Yet it still doesn't work.Is this the only way to get assistance with this software? I'm trying to evaluate the software for possible purchase, but if they don't support the software, I don't see that I'd really like to buy it.mark

HI Mark,

I am running on CentOS5, which is equivelant to RHEL5. During the first step of installation. It told me it could not recongize my OS. I ignored the message and install anyway. But after installation, I had the same problem with yours.

In the release note, they say they support RHEL 4,5,6. For others, if you are not using a default kernel on the supported Linux* distributions listed above, use the SEP Driver Kit in VTune Amplifier XE to compile drivers for your kernel. The SEP Driver Kit software can also be obtained via Intel Premier Support.

I create an ISSUE for this problem at my primer support account. And hopfully, someone will help. I suggest you also open an issue for your case.

When I downloaded the demo, there were instructions that said how to sign up for a Premier Support account, but apparently they changed their web site after they wrote those instructions, so I haven't figured out how to do that yet. I'll search around again for how to do that.When the installation runs, it does compile and load the driver (and if you try to load it again, it says it's already loaded), so it's not very clear what's going on.Thanks,mark

Hi All,

After installing the product, please check if there is driver loaded,
lsmod | grep sep ; vtune amplifier XE driver name is sep3_1

If you can't find it, or driver is incorrect, go /opt/intel/vtune_amplifier_xe_2011/sepdk/src:

1)rmmod-sep3; optional, if found the driver, want to unload it
2)build-driver
3)insmod-sep3
4)boot-script --install

Regards, Peter

Hi Peter,This is what I get, so it appears to be there:# /sbin/lsmod | grep sepsep3_1 72240 0However, the gui still says it isn't there and doesn't allow anything to be run that needs it.mark

Hi Mark et al,

The error message you are seeing is a clearindication that VTune Amplifier XE GUI (Lightweight hotspot or any event based sampling analysis type) can't access the sampling driver.

In addition to sep3_1 driver, we load another driver called PAX. Could you please check if you pax driver is also loaded. (lsmod | grep pax)?

If it is loaded and if things are still not working then please try Peter's step and then

  • make sure you are part of the "vtune" user group
  • and have permission to access to the devices (/dev/sep3_1 and per_cpu devices under /dev/sep3_1) that are created by the driver. By default the permissions are 660.

By default /opt/intel/vtune_amplifier_xe_2011/sepdk/src/insmod-sep3 script performs the following:

Checking for PMU arbitration service (PAX) ... detected.

PAX service is accessible to users in group "vtune".

Executing: insmod ./sep3_1-x32_64-2.6.27.19-5-defaultsmp.ko

Creating /dev/sep3_1 base devices with major number 247 ... done.

Creating /dev/sep3_1 percpu devices with major number 246 ... done.

Setting group ownership of devices to group "vtune" ... done.

Setting file permissions on devices to "660" ... done.

The sep3_1 driver has been successfully loaded.

If you are not part of the vtune group then you can add yourself to vtune group or use insmod-sep3 g option to give access to your group while loading the driver.

Please see the insmod-sep3 options:

Usage: ./insmod-sep3 [ options ]

where "options" are the following:

-g | --group group : restricts access to the sep3_1 driver to users in the specified group; if this option is not provided, the group "vtune" will be used

-p | --perms : fileperms restricts access to the sep3_1 driver based on the specified file permissions; if this option is not provided, then file permissions "660" (or equivalently, "ug+rw") will be used

-q | --query : returns 0 if driver is already loaded, non-zero otherwise; if driver is loaded, information on group ownership and file permissions on driver device will be displayed

-r | --reload: attempt to reload all relevant drivers; note that drivers will not unload if they are still in use

Can you also check if you are able to use Hotspot, Concurrencyand Locks&Waits analyses? These analysis types do not use the sampling driver so it should help us understand the problem more.

Regards,

-Levent

Hi all,

I have checked the PAX driver is also running. After unloading and reloading the sep3_1 driver, I got the same error.'Sampling driver should be (re)started.' Other services like HotSpot, Concurrency and Lock&Waits Analyses are fine.

Also, You mentioned the script /vtune_amplifier_xe_2011/sepdk/src/insmod-sep3 and the vtune group. But how could I add my account into the vtune group ? Do I need to change the script or just use commands?

In addition, I install the kernal source RPM on my CENTOS 5 platform. But it seems not helpful.

Thanks.

Hi Levent,
Thanks.The problem was that I wasn't in the vtune group (changing the installation to use a different group worked).There really isn't any mention of this in the installation process (the option to change the group is there if you know where to look for it). Also, the error message points you to the documentation which doesn't mention this. Perhaps these are some issues that could be improved.Any ideas on my other issue - that the 32-bit version of amplxe-gui isn't installed?Thanks,mark

I want to know if you use "root" user to install the product (or use "sudo" to do). You have to do this to install sep3 driver with "root" privilege.

[root@NHM02 src]# ./insmod-sep3 -g vtune
Checking for PMU arbitration service (PAX) ... not detected.
Attempting to start PAX service ...
Executing: insmod ./pax-x32_64-2.6.18-128.el5smp.ko
Creating /dev/pax device with major number 252 ... done.
Setting group ownership of devices to group "vtune" ... done.
Setting file permissions on devices to "660" ... done.
The pax driver has been successfully loaded.
PAX service has been started.
PAX service is accessible to users in group "vtune".
Executing: insmod ./sep3_1-x32_64-2.6.18-128.el5smp.ko
Creating /dev/sep3_1 base devices with major number 251 ... done.
Creating /dev/sep3_1 percpu devices with major number 250 ... done.
Setting group ownership of devices to group "vtune" ... done.
Setting file permissions on devices to "660" ... done.
The sep3_1 driver has been successfully loaded.

You should have no problem to run Event-based data collectors under common user (vi /etc/group to check/add user name in "vtune" group).

[peter@NHM02 src]$ cd /home/peter
[peter@NHM02 ~]$ /opt/intel/vtune_amplifier_xe_2011/bin64/amplxe-cl -collect lightweight-hotspots -duration 5
Using result path `/home/peter/r000lh'
Executing actions 75 % Generating a report

Summary
-------

Elapsed Time: 5.053
Executing actions 100 % done

Hi again

I wrote a knowledge base article on this error message and how to fix the problem. It is posted at: http://software.intel.com/en-us/articles/problem-accessing-the-sampling-driver/ . We will also update the documentation accordingly.

Thanks
-Levent

Hi,I've had been having this problem for a long time and I just spent a bit of time and finally got all to work (was becoming absolutely necessary to profile memory access, etc). Instead of the 'vtune' group, set it to the users' primary group, on a root install, made this issue go away.hooroo,K

Sorry to bring back this old thread, but I'm having part of this issue, as well.
In particular, I've noticed that I have no amplxe-gui (or inspxe-gui) in my bin32 directory, but I do in bin64.
If I install on a 32-bit machine, I get the 32-bit gui, but then there's no 64-bit install.

What's going on here?

In 64bit machine, the installer will install two set of binaries (executable) - probably the user wants to launch VTune Amplifier XE in 32bit, who should use amplxe-cl from bin32; otherwise use from bin64 (most of cases).

Note there is no 32bit GUI support from 64bit machine

Regards, Peter

Peter,

Thanks for the response. I realize you wouldn't want to run the 32-bit gui on a 64-bit machine, but we have both 32-bit systems and 64-bit systems that we'd like to be able to run these on. For the C++ Composer, when I use the installer, it installs copies of all binaries in 32-bit and 64-bit directories (icpc, idbc, even idb).

If I install vtune on a 32-bit machine, I get the 32-bit amplxe-cl as well as the amplxe-gui. When I install vtune on a 64-bit machine, I get 64-bit amplxe-cl and amplxe-gui, but only the 32-bit amplxe-cl (i.e. no 32-bit amplxe-gui). Why not? It's clearly in the installer, and I want to be able to run it from a 32-bit machine.

I can't install a second copy on top, from a 32-bit machine, because the installer tells me it's already there. The best I've come up with is to just copy the binary in, but there are also a number libraries and things that aren't getting installed, either. I guess I just don't understand why the installer does things differently for vtune than for the compiler.

I don't know Composer XE product in detail, but I know that Composer XE has no GUI supported - need to be integrated into Eclipse?

I guess that GUI components for VTune are implemented by 64bit code & library, that is why only 64bit amplxe-gui under bin64.

If you have 32bit applications to be profiled in 64bit machine, 64bit amplxe-gui still can be used to analyze your 32bit applications.

VTune doesn't support over-installing the product - both for 32bit machine and 64 bit machine. AndVTune doesn't supportto profile64bit applications in 32bit application.

Regards, peter

Composer XE has no GUI, but the debugger (idb) does. I'm not referring to eclipse at all.

As I already mentioned, I'm not trying to profile any applications across different architectures. However, I do want to be able to profile 32-bit applications (on 32-bit machines) and 64-bit applicationes (from 64-bit machines) using the same install of vtune (on NFS), so that we don't have to mainain two separate installs.

When I install vtune from a 32-bit machine, I get the 32-bit version of the gui, command-line tools, and libraries. When I install vtune from a 64-bit machine, I get the 64-bit version of the gui, command-line tools, and libraries, but only the 32-bit version of the command-line tools, and a subset of the libraries. Some of the 32-bit libraries are missing, and the 32-bit gui is nowhere to be found. Clearly the installer has the 32-bit version of the gui and libraries, as they get instaled when on a 32-bit machine, but I don't understand why they don't get installed on a 64-bit install.

Compare this to the compiler toolchain installer, where the installer installs both copies of everything (libraries, gui binaries and command-line binaries) when installed from a 64-bit system. It might even install everything when run from a 32-bit system, but I don't feel like uninstalling so that I can test reinstalling right now.

So I'll ask my question again - why do the installers work so differently, and how can I get both copies of the binaries using an approved method?

Now your requirements is clearly...there is a 64bit machine as NFS, which installed VTune Amplifier XE, so other 32bit machines and 64bit machines can access this machine to run VTune. However only amplxe-guiis installed underbin64, no amplxe-gui under bin32. Thus,thereis no way to run VTune GUI from 32bit machine when profiling 32bit application.

The temp workaround is to use command line (32bit), then display resultsin 64bit machine.

I will send this feature request to engineering team, and post any progress later.

Regards, Peter

Actually if the user doesinstall.sh --SHARED_INSTALL - all 32-bit/64-bit executable and libraries are put in NFS machine.

Yes, you're correct. That did get it to work. Thanks!

One final question on a related note - is there some similar flag I can use to get side-by-side installs of different versions (tagged with numbers, and symlinked to the most recent), similar to how the Compiler installer does it?

Thanks again.

The installer will detect existing prior version, should uninstall it first then install the new version.
Only one version can be installed in one box.

Regards, Peter

Yes, I recognize that this is the way the current installer works, but is there some important reason I'm not realizing that would make having more than one version installed on a machine undesirable?

Again, I'm working on NFS, so being able to have a second version at the same time for a transition period is very desirable. And at two, you might as well leave them all in case there's ever a compatibility issue...

Hi, I'm trying to run intel vtune power analysis on intel(R) Core(TM) i7-3632QM CPU running Ubuntu 13.04 i keep getting "Power driver is inaccessible. Make sure the driver is anstalled and you have permission to access it." I tried buiding and loading drivers manually, the sepdk builds and loads correct but the loading powerdk driver gives error "

Setting group ownership of device to group "vtune" ... ./insmod-apwr: 475: [: vtune: unexpected operator
Not managed to install the driver with the proper group. Wrong group is  vtune
Setting group ownership of device to group "vtune" ... ./insmod-apwr: 475: [: vtune: unexpected operator
Not managed to install the driver with the proper group. Wrong group is  vtune
Setting group ownership of device to group "vtune" ... ./insmod-apwr: 475: [: vtune: unexpected operator
Not managed to install the driver with the proper group. Wrong group is  vtune
./insmod-apwr: 487: [: vtune: unexpected operator
Setting file permissions on device to "660" ... done.
./insmod-apwr: 514: [: vtune: unexpected operator
./insmod-apwr: 528: [: unexpected operator
The apwr3_1 driver has been successfully loaded."

 

Could it be that my processor is not supported?

 

"

You may check:

1. Add your user account into "vtune" group

2. Run "sudo ./build-driver" so generate apwr3_1.ko which is "root" for owner/group

3. Run "sudo ./insmod-apwr"

My version is Ubuntu 13.10, it works. Your i7 processor should be supported.

Thanks Peter. Pls can u elaborate on how to add user account ito vtune group

Thanks. Fixed. I reistalled and did custom installation restricting power analysis driver to group "my username"

Hi all, I was profiling a c++ code.But it is taking a long amount of time to collect the data.The application runs fine but hotspot analysis only shows collecting data.

@ Deepak S

I think that you ran basic hotspots, how long did you run application? Did you launch target application by VTune? VTune will stop after application's terminating if VTune launched application. Did you mean finalizing time was extreme long? Can you set "-duration" option, for example. 30sec to reproduce this issue? 

Leave a Comment

Please sign in to add a comment. Not a member? Join today