A dirver problem using insmod-vtune

A dirver problem using insmod-vtune


My OS is CentOS 5.2, and the VTune version is VTune 9.0 update 11.

When I executed build-driver, there's no problem.

But when I execute insmod-vtune, there's an error message like this:


Executing: insmod ./vtune_drv-x32-2.6.18-92.1.10.el5smp.ko
insmod: error inserting './vtune_drv-x32-2.6.18-92.1.10.el5smp.ko': -1 Invalid module format

Error: sampling driver failed to load!

Please check /var/log/messages for additional information.

You may need to build a sampling driver for your kernel.
Please see the sampling driver README for instructions.


I've been searched for some topic but there's no one used CentOS5.2.

Is this the problem caused by my operation system?


4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

If there's any difference between RedHat 5.2 and CentOS, it's a bug in CentOS. You would see such a problem if you used the wrong architecture of gcc, for example using the 32-bit gcc on x86-64 OS. If you can't resolve the problem, please submit a request for help on your premier.intel.com account, where you would have to give some of the necessary information.

OH, I am sorry about giving not enough information for my question.

The OSI am using is CentOS5.2 i686, not 64-bit OS, so I guess the gcc

I used is the right one...

Anyway I'll try it, thanks :)

Oh, I solve this problem by downloading a new and correct version of kernel.......

It means... It's all my fault...:(

Leave a Comment

Please sign in to add a comment. Not a member? Join today