Error "connection to server lost"

Error "connection to server lost"

Yesterday I downloaded VTune for a project I'm working on but I am having difficulty on getting it to run on the machine that I require it to run on. The installation works fine however when I attempt to run vtlec the eclipse browser run fine for a few moments before comming up with the following errors after closing.

I use First User Wizard ,and get the


"Connection to server lost"



4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

This error might not be related to VTune per se. Can you please try to see if the vTune command line works/ Something like this:

./bin/vtl activity -c sampling -d -o "-cal no -ec (en='CPU_CLK_UNHALTED.CORE' :sa 28330000)(en='INST_RETIRED.ANY' :sa 28330000) -sm ebs -si 1" -app /the/path/to/your/app/to/sample,"parameters list for your app separated by commas" run

The sampling after value (sa) parameter might need to be adapted for your CPU frequency.

The tb5 file (with the sampling data) should be in your_vtune_directory/global_data/vtserver_/sampling.tb5.

Please let us know if this works.



I use the above command ,and come with the same error:

"connection to server lost"

I type the following command:

[root@cu01 bin]# ./vtl activity Testdemo -c sampling -d 30 -o "-cal no -ec (en='CPU_CLK_UNHALTED.CORE' :sa 28330000)(en='INST_RETIRED.ANY' :sa 28330000) -sm ebs -si 1" -app /opt/intel/vtune/samples/vtunedemo/vtunedemo run
VTune Performance Analyzer 9.0 for Linux*. 30 DAY EVALUATION LICENSE
Copyright (C) 2000-2007 Intel Corporation. All rights reserved.

vtserver.bin: run_handler.cpp:37: run_handler::run_handler(vtsa_sys_info *, VTEvents *, const user_callback_funcs_s *): Assertion `p_events_mgr != 0L' failed.
Connection to server lost


waiting on line

I use "First use wizard",and run gsexample2a  sample.
I come with the same error:
Connection to server lost"
application to profile:
Application to launch:/opt/intel/vtune/samples/gsexample/gsexsample2a
Application arguments:datafile.txt
Working directory:/opt/intel/vtune/samples/gsexample/
and click "finish",I get the same error:
connection to server lost.

Leave a Comment

Please sign in to add a comment. Not a member? Join today