How to get XScale/WinCE version?

How to get XScale/WinCE version?

Hi, I downloaded the trial version of VTune 9.0, but there is no hint of support for WinCE and I don't see anything on the VTune web site about it. How do I get a trial version of VTune for WinCE?

13 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Please see the following notice in the Release Notes:

Marvell PXA* family of processors Information

As of November
8, 2006, the Intel Cellular and Handheld Group was acquired by
Marvell.Support for the Marvell PXA family of processors
based on Intel XScale technology is now provided by Marvell. The
VTune Analyzer can still be used to analyze the performance of Marvell PXA processors, but two things have changed.

First,
the Marvell PXA collector and documentation package must be downloaded
separately. Eventually the collectors will be moving to a Marvell
hosted web-site, but for now they are available
in the
Intel Registration Center
download area with the VTune analyzer 9.0 for Windows* product under the
Remote Agent link for the 9.0 release.
(These
collectors are only required if you are using the VTune analyzer to tune
Marvell PXA processors. Users tuning only non-PXA processors should not
download the PXA collectors.)

Second, support for the analysis of PXA processors is now being provided
by Marvell. To receive a support account, send email to:


account_req@support.marvell.com
. Once log-in details have been
received, log onto the Marvell support website at:

https://support.marvell.com.

When viewing downloads on the Intel Registration Center, select VTune9.0-24052 as the Minor Version to see the PXA remote agent.

I went to the link to the "Registration Center" and clicked "Registered users login" but got this error:

HTTP 500 - Internal Server Error

We're sorry, there is a problem with the page you are trying to reach and it
cannot be displayed.

I'll try again tomorrow.

No, I still can't reach the login page. Internal Server Error.

Hmmm. Dunno. It should redirect you to https://registrationcenter.intel.com/regcenter/register.aspx. Try that directly.

Right. I go to https://registrationcenter.intel.com/regcenter/register.aspx and click "Registered Users Login", then I'm taken to https://welcome.intel.com/scripts-util/500.asp?aspxerrorpath=/Login.aspx where it says "HTTP 500 - Internal server error".

My trial period runs out in under 3 weeks :(

Hmm, so I tried to register again and after filling out two or three forms I got this error:

Error

We have experienced a critical error in our authentication system.

https://registrationcenter.intel.com/RegCenter/Error.aspx?err=25253

Is the Intel web site under construction or what?

I found the problem: Firefox. Apparently this site just isn't compatible. Earlier I had tried to login with IE and it didn't work, but now it does.... I guess I had put the address of the error page in the IE address bar instead of the page that came before it.

The WinCE data collector was hard to find! The download page (which isn't even labeled as being a download page) that has a download link for "Remote Agent" is actually a link to some sort of Linux collector only. The default minor version, VTune9.0U7-719, and all other minor versions except VTune9.0-24052 only provide Linux collectors.

By selecting VTune9.0-24052 I got access to "PXA2xx-Collectors.zip", which contained 6 other zip files. One of these (XScale.zip) contains miscellaneous chm files, while the others appear to contain installers for different platforms and processors.

Now I have a new problem. 4 of the 5 installers are labeled as being for "PXA27x". Unfortunately I have a PXA255 processor. I tried installing the version called PXA27x_WCE50 on my WinCE 5.0 machine but when I run the Data Collector on the device, I get the message "Initialize Failed!"

The last installer is called PXA2xx.zip, but unfortunately it seems to be for VTune 7.2 instead of 9.0. Will this version work with my processor? Is there a way to get VTune 7.2?

I'm sorry about the confusion of what to download. I tried to explain that at the bottom of my post of 05/21/2008.

The "Initialization Failed!" message is typical of an OS image (WinCE 5.0, in your case) that has not enabled the PMU. Please review the documentation that is part of the PXAxxx collector.

I just did a search on our support site (http://support.intel.com) and found this previous forum discussion and this documentation, which may help.

maddlanders:The "Initialization Failed!" message is typical of an OS image (WinCE 5.0, in your case) that has not enabled the PMU. Please review the documentation that is part of the PXAxxx collector.

I just did a search on our support site (http://support.intel.com) and found this previous forum discussion and this documentation, which may help.

The documentation you link to appears to be for Linux on PXA.

The thread you link to has no helpful information except for one poster who said "Initially I got the Initialize Failed Error which got resolved when I included the PMU component in the OS image." However, he did not say how to include the PMU component in the OS image (is it even possible without Platform Builder? why would anybody assume end-users have the freedom to change the OS image?) Anyway, it's not clear to me what PMU is. It's some kind of product made by Intel related to data collection, right?

Update: the collector comes with a help file (installed to C:Program FilesIntelVTuneRDC for PXA27x - WCE50HelpXScHostDCSampling.chm) which simply says to run the Data Collector on the target machine (or to run VTRemoteSvr.exe for "SRDC" mode) and then to create a New Activity. It doesn't say anything about this "Initialize Failed!" message. I searched the help file and this message is never mentioned.

I searched the file for "PMU" and got two hits, both of which said only this:
"The performance monitoring unit (PMU) on systems with Intel XScale technology PXA25x/PXA26x processors can support two event counters.
The PMU on systems with the PXA27x processors can support four event counters."

PMU = performance monitoring unit.

So, no one expected end users to be able to rebuild the OS image. Initially, when Intel began providing support for profiling on PXA processor systems, we supported a very finite set of platforms. Only OSVs can rebuild the OS image. You need to go to the OSV and request a version with the PMU enabled and they may or may not have it.

Basically, any ol' PXA device is not enabled for profiling and that is an issue you need to take up with the HSV/ISV/OSV. I'm sorry, but that's the way it works in this embedded world.

I had no idea my OS image was unusual.

I talked to one of the people in charge of the OS image... they looked at the issue, briefly, and said that this PMU thing is not a standard component and may require "extensive changes" to add to the OS image. Is this accurate, or is there an easy way to add PMU support?

There are a lot of dependencies and some of them are on your image. In other words, I can't answer your question. Your engineer has a better idea of your environment than I do.

I'm sorry I can't help more, but this is not something with which we have expertise, anymore. If you want to pursue enabling this support, I think it would be best for you to contact Marvell and see if they can help.

Leave a Comment

Please sign in to add a comment. Not a member? Join today