Error: Failed to configure the collector.

Error: Failed to configure the collector.


I'm a newbie to VTune running V9.0 on RHEL4U4. I'm profiling a large (50MB) EDA Linux application. The "First Use" sampling activity works fine.

When I run the same configuration as a "Call Graph" activity, the activity aborts with an error popup dialog saying, "Error: Failed to configure the collector". This occurs apparently before the application begins execution. I could not locate debug information and could not turn up a definition of the error message in the program help or this forum.

Any suggestions? Could the executable size be exceeding a limit?


7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

A configuration change cleared up the error message. This issue has been resolved.

Hi Ron:

I am useing the newest version of Vtune on the Linux and got the idetical error message.

Woudl you please share your experience on how did you change the configuration to resolve this problem?


It's been awhile, but if memory serves, this problem was caused by running VTune on a wrapper script instead of the executable program itself. My impression is that the sampling activity was able to resolve symbolic links (symlinks) in the shell script, while the call graph activities could not.

Perhaps one of the VTune developers can confirm if this is expected behavior?

The fix was to run VTune on the executable itself, not on a shell script that calls the executable. In general, this seems a better approach to avoid problems.


Dear Ron:

Thank you for the quick response. I am running the vtlec (Vtune 9.0) on a Linux system.
The application that I tried to profile is a Linux executable and it is compiled with Intel's C++ compilee (icc) using the "-g -O2" flags.

We recently migrated to the VTune 9.0.
To make sure that I follow the correct steps, I went back to the gsexamples and did a call graph run on the gsexample2a. The Vtune does generate the call graph for the gsexample2a beautifully.

Unfortunately, when I did the call graph run on my application, the VTune gave me an error message saying:
"Failed to configure the collector." I struggled for two days and can not resolve this problem. It is just puzzled me.

My application typically takse about 3 minutes to run. It will take a whole hours to run the sampling with the vtlec although I have the VTUNE_USER_DIR defined locally.

Thank you for all the helps.




You might look into the Performance Tuning Utility:

This is a beta-level replacement for VTune. PTU does statistical call graphs. The call graphs run in essentially the same time as sampling. We also were not able to use call graphs with VTune in many cases because they just took too long to run.


Hi Ron:

Thank you very much.
I will take a look at it.



Leave a Comment

Please sign in to add a comment. Not a member? Join today