Intel VTune 9u1 sampling hangs on Fedora Core 6

Intel VTune 9u1 sampling hangs on Fedora Core 6

Hello all

I just installed Intel VTune 9.0u1 (which supports Fedora Core 6 as far as I can tell) on my FC6 system. I'm using kernel 2.6.20-1.2948 on an Intel Core 2 Duo T7200 CPU (Dell Inspiron 9400).

After I start the Intel VTune graphical user interface, I select the "First Use - Run this first" activity. Leaving all the setting unchanged, I hit the Finish button. As soon as I do this, my machine immediately becomes completely unresponsive.

Has anybody been able to get this release of Intel VTune to work on Fedora Core 6? Which kernel did you use? Is there any way to figure out why it's causing my machine to hang? Is there anything I can try to avoid this problem?



Albert Strasheim

17 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Albert,

Thishappens on the latest FC6 kernel 2.6.20-1.2948 and appears to be a bug in the VDK driver. Until this is further understood you can use a workaround for VDK thathas been attached to the post. It can be used with VTune 9.0 Update1 on Linux systems running kernel 2.6.20 and later (e.g., FC6 with the latest updated kernels).

Please let me know if this does not help.


Downloadapplication/zip scr30638_workaround.zip1.47 KB

The patch made some difference, but unfortunately the problem isn't fixed.

I followed the instructions in the README to apply the patch and rebuild the driver. Now when I hit Finish I see a "Sampling Activity" item appear in the Tuning Browser and then the system hangs about a second later.

In /var/log/messages I see the following:

May 23 12:59:30 ratbert kernel: VSD: [Warning] sampling driver opened but never used
May 23 12:59:30 ratbert kernel: VSD: VTune Performance Analyzer SMP sampling driver v0.9486 has been unloaded.
May 23 12:59:34 ratbert kernel: VSD: VTune Performance Analyzer SMP sampling driver v0.94861 has been loaded.
May 23 12:59:34 ratbert kernel: VSD: tasklist_lock symbol found at address 0xc073ba00
May 23 13:00:50 ratbert kernel: NET: Registered protocol family 4
May 23 13:00:50 ratbert kernel: NET: Registered protocol family 5
May 23 13:00:57 ratbert kernel: VSD: [Warning] dsa_mmap: 1 != 2 = num_dsa_open
May 23 13:00:58 ratbert kernel: BUG: unable to handle kernel paging request at virtual address 6898ec88
May 23 13:00:58 ratbert kernel: printing eip:
May 23 13:00:58 ratbert kernel: f8e856d7

The machine then hangs and its Caps Lock and Scroll Lock lights flash (presumably due to the kernel panic).

Can I use Fedora's 2.6.18 kernel temporarily? With or without the patch?




Yes, you can use 2.6.18 kernelwithout a patch (it's only for kernel 2.6.20). I'll inform you if I find something on your case.


Just wanted to inform you that I have the same problem on my desktop machine, a Dell Dimension 5150 with an HT Pentium 4 processor. I use the same version of VTune (9.0u1) and the same Fedora 6 kernel (2.6.20-1.2948).

I also tried to apply your patch, but had the same luck. It runs for 1-2 seconds and then hangs the whole system. I tried both from Eclipse and from the command-line. When running from the command-line I get the following error message from the kernel:

EIP: [] .bsr_10+0x4/0x1c [vtune_drv] SS:ESP 0068:f7d11e30
BUG: sleeping function called from invalid context at drivers/char/vt.c:3394
in_atomic():0 irqs_disabled():1

Hope that helps somehow,

Ioannis Venetis


Thank you for the information. It looks like the patch works not for all systems. So recommendation for nowwill beavoid running sampling on 2.6.20 kernels and possibly use 2.6.18 kernel.


Ioannis and Albert, do you use IA32 or EM64T FC6?

I'm using IA32 FC6. Thanks.

I am using IA32 FC6 too.

Thanks, this is useful info.

FYI, the VDK driver causes kernel panic on FC7 kernel 2.6.21-1.3194 running on Core Duo T2500, too, both with and without the patch.

The problem with system crash on updated FC6 and F7 is confirmed. It happens on ia-32 systems running with kernel 2.6.20 and later. VTune developers are working on solutution which will fix this in driver code.

regards, Andrei


Just wanted to ask about the status of this problem. Is any patch/update to be expected any time soon?


No big progress. It's likely the issue will not be fixed in comming VTune for Linux 9.0 update 3.

Big changes in the 2.6.20 required us to significantly rework VDK on ia32. I beleive the fix will be published here as soon as it's ready and will go in the one of the next product updates.

thanks, Andrei

FYI the above patch _does_ fix the issue for Fedore Core 7 64-bit running kernel (it doesn't lock up the machine anymore anyhow).

When will update 3 be released?

For that matter, did I miss update 2?


An update with a fix for this problem has not been released. To insure that you receive the update, please submit an issue at Intel Premier Support.

It also does this on kernel level:
2.6.18-53.1.14.el5 #1 SMP Wed Mar 5 11:37:38 EST 2008 x86_64 x86_64 x86_64 GNU/Linux

vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Intel Xeon
X5450 @ 3.00GHz

Leave a Comment

Please sign in to add a comment. Not a member? Join today