Source View not working

Source View not working


I'm currently evaluating VTune 8.0 with our project and I'm having trouble getting the SourceView to work. Callgraphs work fine but when trying to deeper analyse the code by clicking SourceView on a module in the CallGraph results window I get a "Internal Error: could not find file(s)".
I tried to explicitely set the directories for my sources with no effect.
Is there anything else I'm missing?

12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Alexander,

Could you pleasetry the latest released VTune 8.0.2 build #608? Does the problem still occur?



I'm not sure which version exactly I'm running. I checked the evaluation download link and it's the "vtune_linux_8.0.245.tar.gz", which is still current. (same version I installed)
I might not be entitled to upgrade since it's an evaluation version, but I'd like to know if and how well the SourceView is working with our project prior to purchasing VTune.


Build #608 can also be downloaded for evaluation from

I tried out the #608 build but it still doesn't work. Is there any way to see which directories VTune checks for my source files or is there maybe a way to get a more detailed error message?

You can specify directories for searching source file by using menu "Window"->"Preferences", then select in the tree on the left "VTune Performance Analyzer"->"Directories", and choose Context = "Project...", Show directories for = "Source fies" - now you can add your directories with source files.

Please make sure that your binary files have full debug info (compiled with -g)- line number information, symbol information andsection ".debug_line" should contain path to source file.


Thanks for the help so far. Right now, I'm trying to get the supplied examples to work at least. They're compiled with full debug info (-g) and when running via gdb or idb, there is no problem stepping through each line of code.
But in VTune I still can't use the SourceView. I tried adding the full path to the binary and the source code to the VTune Directories but I still get the same error.

After using the first-time wizard, I also can't see any symbol names (Symbol available = NO). It seems like all that's really working is the callgraph analysis...

I'm really surprised that the VTune Source View doesn't work on provided examples. We didn't see any problems with them in our lab...Seems that the root cause is specific for your environment...

What platform you use? OS, kernel, glibc, architecture?

Did you have any warnings/errors while instalation?

Do you have any warnings while GUI start?

Let's check also whether it's a GUI issue only, or the same problem happens in command line. Please run in console:

$ /bin/vtl activity -c callgraph -app /samples/vtunedemo/vtunedemo -moi /samples/vtunedemo/vtunedemo run

$ /bin/vtl view -code -mn vtunedemo -fn test_if-sf /samples/vtunedemo/vtunedemo.c

What output you have?

Ok I ran the command line tool and the error seems to be the same (no symbols found at the end of the callgraph data collection and the internal error message).

Updating Call graph database...
Trying to find symbols for module (4 / 5) /opt/intel/vtune/samples/vtunedemo/vtunedemo

However, I tried to re-run the tool with root priviledges and it worked without a problem!!
So this seems to be a problem with driver and/or directory permissions I guess.
I installed the driver with the same group ID as my user account, and I can definitely access/write the temp directory and read the binary with this user.
Any other permissions I might have forgotten...? The installer didn't mention any specific problems besides the difference in the Java Runtime I use, so I thought there was no problem on this side.

1) Make sure below directories are available for read/write by your group ID (permissions = 755):


The global data directories are used by VTune to save binary symbol information.

You can re-define location ofglobal data byre-setting VTUNE_GLOBAL_DIR variable to your own directory.

2) Check that /tmp/vtune_ was created and Cache folder inside is writable

Thanks! That fixed the problem so far. The permissions for the ./ISM and the ./rdc directory were wrong. VTune only complained about the /global_data dir right after installation which turns out to be not enough after I fixed it. (it doesn't complain about the other two directories, maybe it should ;-) )
I now have the source view ready for our project but there aren't any sample counts for the method I'm interested in...

I'm really glad that the initial problem was resolved! And I beleive you're right - VTune should have warned about wrong permissions on ISM folder; i'll escalate the issue to VTune engineers.

As for the absence of sample counts on your method in Source View: did you checkdisassembly view also? Weren't there any samples in your method address range?

Leave a Comment

Please sign in to add a comment. Not a member? Join today