VTune and IVF 9.0

VTune and IVF 9.0

Since installing IVF 9.0 I have been unable to get VTune to recognize that debug information has been produced and is available. All the appropriate settings are in place both in the compiler and the linker to generate debug info; and a pdb file appears in the appropriate directory. I can debug the code from within the IDE, so I know that the debug info is there and available.

When I run VTune (both within the IDE and standalone) it does not instrument my module, saying that debug information is not available. When I configure the call graph activity it says that there is no debug information available. I have (repeatedly) gone to "advanced" and clear the cache to make sure that it isn't using old information. I've even removed the cache folder in the temp directory so that it creates it new. The Problem persists.

All of this is true with old code that I've been working on and also with a brand new project using the simple sample code that is supplied with IVF 9.0 to test its operation (the code for the numerical integration of the sine function). VTune does not instrument it either.

Is there a new incompatiblity? Is there a setting I'm missing? Any help would be appreciated.

David L. DiLuara

12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hey David,

Nice to see you posting in here.

Rumor has it there is a switch setting on the new compiler to establish the "old style" debug info. I'm still learning about this myself.

What compiler switches are you currently using? (Can you cut and paste here?)

cheers
jdg

Hello,

Here are the settings that the IDE shows for the command line of IVF 9.0. I'm compiling in debug mode.

/nologo /Zi /Od /module:"$(INTDIR)/" /object:"$(INTDIR)/" /traceback /check:bounds /libs:static /dbglibs /c

If you find the mystery switch, please let me know!

David

If you haven't yet, please try this switch:

-mIPOPT_ninl_debug_info=F

Be sure to report back, too, if you can.

cheers

jdg

No change. Though what you had in your posting doesn't look like an IVF Windows compiler switch--it's looks like a switch for the Unix version of IVF. The Windows compiler switches all begin with "/" and those for the Unix compiler begin with"-"

When I tried the version with "-", itseems to have been ignored. The version with "/" haulted the compiler with Error Code 1. I interpolated a bit and thought that the switch that you suggested might be calling for full debug information
[. . . debug_info=F]. For the Windows IVF compiler there is a switch for full debugging: /debug:full but I've already used that. No effect.

I'd rather not go back to IVF 8.2, but is that what I'll need to do?

Regards,

David

GOOD catch dd, you couldn't be more right, I amindeed alinux geek and for some reason, was up to my neck in Linux command lines while thinking about your posting.

Don't assume you have to backup from the IVF 9.0 just yet based on my comments: the Windows guys around here are checking their facts before getting back to you.

Stay tuned!

cheers
jdg

Message Edited by jdgallag on 07-15-2005 01:57 PM

David:

I suggest you load the EXE into the Static Module Viewer of the VTune analyzer (see File menu). With the Functions with source information check box checked, can you see all the functions you expect to see? If not, then there is a problem with the debug info. If it looks okay, try right-clicking on a function and selecting View Source. Does that work?

The Static Module Viewer is an effective way to verify symbol information.

Regards,

Regards,
MrAnderson

Dave,

Thanks for your suggestion. The Static Module Viewer reports thatNO symbols are available. Yet, this same EXE runs in debug mode in the IDE--I can stop execution, examine various variables, load variables into the watch window, etc. I just don't get it.

Has anyone there duplicated this problem? Steve Lionel over in the IVF forum initially thought this would be a VTune problem (I went there first) and moved this query over to this forum.

As I mentioned, I don't want to go back to IVF 8.2 but this isn't looking good.
Let me know if you think this problem might just have to float . . .

David

Hi David:

What would be best is for you to submit an issue at Intel Premier Support against the VTune analyzer and provide a test EXE that demonstrates the problem. Then we can investigate where the problem is.

Thanks,
Dave

Regards,
MrAnderson

Hi,

I had exactly the same problem as David and wasted several hours trying to figure out some new "magic" compiler option. In the end I had reinstalled Vtune and the problem had disappeared. Looks like one has to reinstall Vtune after upgrading to IVF 9.0

Yuri.

Thanks, izryu! I wonder if anyone else has tried this with any success?!

Regards,
MrAnderson

Hello,

On some of our computers I have seen this, and I have not managed to determine the reason. A temporary workaround was to have both IVF 8.1 and IVF 9.0 installed together with VTune 7.2. Then Vtune worked with both 8.1 and 9.0 - don't ask me why. The recommended installation order is:

1. IVF 9.0.

2. VTune 7.2.

3. IVF 8.1

I hope this works for you.

Best Regards,

Lars Petter Endresen

Leave a Comment

Please sign in to add a comment. Not a member? Join today