Intel VTune(TM) Performance Analyzer 3.0 Beta Test Archive

Intel VTune(TM) Performance Analyzer 3.0 Beta Test Archive


This thread is an archive of the postings that were posted during the beta test program for this software. The product is now currently available for sale or evaluation at:

http://www.intel.com/software/products/vtune/vlin

Message Edited by Judy on 02-23-2005 03:37 PM

Message Edited by Judy on 02-23-2005 03:37 PM

44 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi,

A feature request for the View Source Code of VTL3.0: a Fortran language color parser.

Cheers,
GM.

Hey GM,

Are you thinking of an existing, particular application that has the look and feel you prefer here? If so, post it here so we can have a look.

cheers
jdg

Visual Studio, at least the way it came with CVF, and many editors, e.g vim and emacs, do colored syntax display.

Hi,

I don't have a particular tool as an example, but gedit for Linux with the optional fortran.lang file, may be a starting point.

For me, it is just a little annoying going to a source code view of a function on VTL3, and find it colored in C/C++ keywords when it is a Fortran file. (Is there a way to turn it off?). It is just a visual aid, but a nice one.

Of course, to implement a Fortran Parser for the Eclipse environment would be the best, as the one that exists for C/C++ development (I think the same one can be easily extended for it). Then, everything from coding to profiling can be done on the same environment.

Cheers,
GM.

Hi Guillermo:

What extension do your Fortran source files use? If you open the VTune analyzer Options dialog and select Syntax Highlight under Source View, you will see that the analyzer is configured to use a Fortran color scheme for files with the following extensions: *.f;*.fpp;*.for;*.f90;*.f95. If this is not working, we should report it. Can you submit an issue at Intel Premier Support and attach a sample module and source file?

Thanks,

Regards,
MrAnderson

Hi,

First of all, sorry for the delay. I am using *.F extension (capital F), so that may be the reason. Currently the beta has expired, so I have to wait until the official release.

Cheers,
GM.

Hi,

I was not able to locate the option you mention. The closest is at:

Window -> Preferences -> VTtune -> Source View, but there is no option there to select syntax highlight mode or association.

Cheers,
GM

Sorry. I was confused and referring to the Windows*-based VTune analyzer. I expect as the Linux*-based product matures, you will see this support.

Regards,
MrAnderson

Hi, I want to share my experiences installing the VTL3.0 beta. These are my observations:

1. The option to proceed if the installation platform is not supported is only available in the "custom" menu.

2. Get the following errors while installing:

---
The VTune Performance Analyzer 3.0 for Linux* is being installed...

The install destination has been set to /opt/intel/vtune

Registering VTune Performance Analyzer files, please wait...
It may take several minutes.

Registration is done.

Note: Performance tuning, by its nature, collects large amounts of data and
hence the product requires creating a common directory for global data.
The default directory will be /opt/intel/vtune/global_data. If this is
acceptable please just hit enter or type in the full path of the
directory at the prompt. Ensure that the chosen path on disk has
adequate space for all users. Where do you want to create directory
for global data?
Specify directory starting with '/'. [ /opt/intel/vtune/global_data ]:
install.sh: line 2196: [: /home/marcus/Intel/vtune: binary operator expected
install.sh: line 2196: [: /home/marcus/Intel/vtune: binary operator expected
install.sh: line 2196: [: /home/marcus/Intel/vtune: binary operator expected
install.sh: line 2196: [: /home/marcus/Intel/vtune: binary operator expected
install.sh: line 2196: [: /home/marcus/Intel/vtune: binary operator expected

Note: The VTune Performance Analyzer 3.0 for Linux* requires a user to be a member of
the "vtune" group. If users and groups on this system are
------

This is due to the installer being in a path with spaces. The correct path mentioned should be "/home/marcus/Intel/vtune files/..."

3. The following issue happens if installing Eclipse:

------
Where would you like to install Eclipse* Platform RunTime Binary, Version 2.1.3 for GTK* [/opt/intel]? : /opt/eclipse/rtl

Location "/
opt/eclipse/rtl" provided by you does not exist.
Would you like this folder to be created (Yes/No)? [Yes]
Press ENTER key to accept default choice, or input a valid choice : /opt/eclipse/rtl
------

The directory is not created because it does not chain the creation with mkdir -p (neither eclipse or rtl exists at this moment).

4. Also:

------
Which of the following would you like to install?
1. Eclipse* Platform RunTime Binary, Version 2.1.3 for GTK* (Recommended). (Installed)
2. Eclipse* Platform RunTime Binary, Version 2.1.3 for Motif*.
3. WebLogic* JRockit* 1.4.2 JRE for Linux* (Recommended).
b. Return to the main menu.

Please type a selection: b

sh: line 1: cd: /home/marcus/Intel/vtune: No such file or directory
Exiting...
-------

This has also to do with the spaces in the name of the directory.

5. Eclipse script vtlec is not updated.

If you run the eclipse installation again and change the execution package, the vtlec script is not updated to point to the selected option.

Cheers,
GM.

Update:

Tryed to install on Gentoo, the installer gives the following error after the Licenses (all 4) acceptance:

---
Enter 'accept' to continue, 'reject' to exit: accept
ERROR: unable to find command $c
Please add the location to the above commands to your PATH and re-run the script
Please press Enter to continue
-----

Cheers,
GM.

Question to the readers of this forum: how many Gentoo users out there? Just curious here, inside Intel.

:)

Reply to this note and let us know if Gentoo is a distro that we should be supporting.

cheers
jdg

Here is at least one Gentoo user who would be greatful for Vtune supporting this distro :)

Cheers
PU

Hi all,

when I run my OpenMP program using the cli version
of VTune 3.0b, it runs with one thread when I set OMP_NUM_THREADS=1,
as expected (this is for callgraph profiling). When I do the same
under GUI (vtlec) control, it insists on running with 2 threads. I
have tried setting OMP_NUM_THREADS=1 on the command line before
starting vtlec, as well as setting it in the 'Advanced' project
options (user-defined environment), but this does not help. OMP_NUM_THREADS
seems to get ignored when the GUI is running.

Any ideas?

Georg.

PS: This is on a dual Xeon, SuSE 8.1, Kernel 2.4.24.

Sometimes, it has been necessary to run a script, in which the environment variables are set before starting the application.

OpenMP programs built with Intel compilers have 2 monitor threads, in addition to those counted under OMP_NUM_THREADS. Intel libguide and linux libpthread each are responsible for one. They normally accumulate well under a second together. I'm not certain from your description whether those are involved.

Hi,

I can see the two helper threads, but there is one additional thread
which collects a lot of CPU time, and it is definitely a compute
thread. Besides, the program uses omp_get_num_threads() to determine
the number of threads it is running on, and this number is reported
as 2.

The script trick works, ok.

Btw, I have checked that the problem does not appear when doing
IP sampling. Strange.

Thanks,
Georg.

Nice to hear from you jon.nall,

VTune shows managed code alongside unmanaged code: we just have to listen differently -- so to speak -- when we deal with unmanaged code in the mix.

Absolutely you'll see both, as long as you tell VTune that you're working with managed code as you set up the session. (Very easy to do, a single click on the data collector setup if you're using the GUI; if you're using the command line, you'll use one of these options: java, applet, or jitprofiling -- for more on that, do a man page on "sampling" or read the User's Guide.)

cheers

jdg

Message Edited by jdgallag on 11-01-2004 02:26 PM

Can someone clarify the license agreement that accompanies the beta program - in particular, can it be used for university research by salaried staff, normally not classified as "non commerical" by Intel?

Did you see something in the license to make you think it could not be used in a commercial manner? If you are concerned about something specific, we can look into it. Otherwise, we do not want to give general statements that might be misinterpreted.

Regards,
MrAnderson

Here is what I found out: the beta EULA does not prevent the use of the software for commercial purposes, however, there are restrictions regarding how the software may be used:

"UNAUTHORIZED USE: THE MATERIALS ARE NOT DESIGNED, INTENDED, OR AUTHORIZED FOR USE IN ANY MEDICAL, LIFE SAVING OR LIFE SUSTAINING SYSTEMS, OR FOR ANY OTHER APPLICATION IN WHICH THE FAILURE OF THE MATERIALS COULD CREATE A SITUATION WHERE PERSONAL INJURY OR DEATH MAY OCCUR."

and, in addition, see the following from the EULA:

You agree to maintain as confidential all information relating to your use of the Materials and not to disclose to any third party any benchmarks, performance results, or other information relating to the Materials comprising the pre-release.
Ultimately, if you have concerns, you should have a lawyer review the agreement.

Regards,
MrAnderson

Hello,
I am new to vtune and have been successful to use the tool
to generate call graph and sampling data for our applications running on x86. I have been using vtune 3.0.

Is there a way to profile the linux kernel code? I am interested to profile for kernel code, especially the functions in kernel when our application runs.

Thanks,
Kallol

I think "sampling" collects data for operating systems code also. There may be an option to display the performance data sorted in the order of the most used functions in the kernel....

Hi kallol:

Yes, sampling data for the kernel can be viewed along with your application sampling data. The requirement, however, is that you have rebuilt your kernel with debug information (i.e., '-g' option on the gcc compiler). Once you have done this and collect data with this debug kernel, you can view statistics for the kernel modules and functions. Note: "debug" does not mean you have to disable optimization, only that debug symbols are generated for the kernel modules.

Regards,
MrAnderson

Also, just to make sure we're all on the same page here: we can't use callgraph on the linux kernel because the callgraph technology re-instruments the code you want to profile. The, during analysis, vtune launches that re-instrumented version of the code to collect data.

On Linux, you can't have two kernels running at once, of course, so that means sampling is the appropriate profiling technology to use when you're looking for kernel data.

cheers
jdg

OS: Red Hat Enterprise Linux AS release 3 (Taroon Update 2) of IA64.
Vtune: VTune30beta

The software gets installed fine, there is no GUI support, ie. no vtlec.

Question: How do we create a project on the command line?

Yes, Kallol, there is no eclipse standard yet for Itanium, so, no vtlec command, just vtl, as you stated. Some good places for you to read:

$ man vtl
$ man sampling
$ man callgraph

User's Guide (sections on sampling and callgraph quick starts)
/opt/intel/vtune/doc/users_guide/index.htm

BUT, that said, here are two quick examples, from memory:

$ vtl activity -c sampling -d 20 -app /my/application run
(this creates and runs a 20 second sampling session on "/my/application")

To view the data:

$ vtl view
or
$ vtl view -gui

(The -gui option shows you a plug in viewer, very snappy, very nice -- use this instead of vtlec, which you don't have anyway on Itanium Linux)

Another sample, callgraph this time:

$ vtl activity -c callgraph -app /my/application -moi /my/application run

view the same way

$ vtl view
or
$ vtl view -gui

Other useful commands:

$ vtl --help
$ vtl version

I hope this helps!

cheers
jdg

Message Edited by jdgallag on 11-22-2004 03:41 PM

/opt normally is created in the / partition. That normally isn't big enough for a a default Vtune installation. Vtune installer doesn't hunt for large enough partitions, but the minimum requirement is way low in practice.
I don't know about Altix, but a common work-around is to mv /opt to /usr and replace with a symlink, so that it still appears as /opt.

When you run "vtl", it checks for space on the global data directory. The way it does this is with a shell script and parsing the output of a "df -k".

My Altix has a df -k that looks like this....

pkerney@pkaltix: 58 % df -k /opt/intel/vtune/global_data

Filesystem 1K-blocks Used Available Use% Mounted on

/dev/xscsi/pci01.03.0-1/target1/lun0/part3

9568000 7601920 1966080 80% /

pkerney@pkaltix: 59 %

The /dev entry makes it go over a line which breaks the parsing.

Edit file file /opt/intel/vtune/bin/clscripts.common and in the routine "check_minimum_space" add another "getline" to make 3, and change the $2 to $1 just below it.

You should now be operational !!!!!

Now a cheat sheet for running it just to help your learning curve.

Compile your program with an added "-g". Note the "-g" does not disable optimisations, it simply adds symbol information to the executable. ie. "-O3 -g" is a valid set of flags. You are VTuning an optimised binary !!!

Run the app just to make sure it works. (My app was pom3d)Then :-

vtl activity -c sampling -app pom3d run # sampling finds the hotspots

vtl show # find out the results to use

vtl view a1::r1 -processes > aaa.txt # output to a file to make it easier to read

vtl view a1::r1 -modules > aaa.txt

vtl view a1::r1 -hf -mn pom3d > aaa.txt

vtl view a1::r1 -code -fn MAIN__ -mn pom3d > aaa.txt

vtl view a1::r1 -gui # use the little icons in the top left to switch views

vtl activity -c callgraph -app pom3d -moi pom3d run # callgraph show the function paths

vtl view a2::r1 -gui

Message Edited by pkerney on 11-25-2004 08:11 PM

Message Edited by pkerney on 11-25-2004 08:22 PM

Good discussion, guys. Please note that this "available space" bug was corrected in the released version of this beta software. The released version will be available in mid DEC, in just about a week (the current plan is on or around DEC 10.) FYI only.

cheers

jdg

What do you get when you do 'vtl view -modules'? Does it show the 'vtundemo' module?

If you believe there is a problem, please submit an issue at the Intel Premier Support web site, including a pack and go file of the results (compressed).

Thanks.

Regards,
MrAnderson

This message comes up in Vtune 7.1A when the 3.0 rdc finishes data collection. I removed the Vtune installation from Windows2000, installed it on XP, went through the 2 hours of data collection, and the same thing happened on XP. The analysis progress bar comes up under Windows 2000, but it sticks at 0%. I can't even find anything about this most frequently occurring error message in the help menu.

A hint from a colleague is that the Windows Vtune GUI exhibits this failure any time there is a message "selected event did not occur," so I am attempting a repeat. The Windows GUI deletes the data collection directories when it fails, so the evidence is gone.

Message Edited by tim18 on 08-25-2004 02:43 PM

Another error I made is that I checked the "start with data collection suspended" box, which no longer is the right thing to do when all you want is to specify a start delay.

Message Edited by tim18 on 08-25-2004 03:02 PM

Tim:

If you are having a technical problem, please submit an issue at Intel Premier Support. We provide help with technical problems at the Premier web site and would be glad to try to help you.

Regards,
MrAnderson

problem was caused by confusion with multiple copies of kernel. Red Hat compounds the confusion by supplying 2 kernels for some EM64T platforms. The plain EM64T kernel which is not identified as smp actually is SMP and the Vtune 3.0 driver build worked with it.
I'm happy to run remote collector from Windows 2000, given that Red Hat doesn't support the video card or mouse on my EM64T.

Message Edited by tim18 on 08-25-2004 08:36 AM

Hi Jon, nice to see your post.

Did you try here?

http://www.intel.com/software/products/vtune/beta/vt_pa_linux_beta_external.htm

Let me know what you see, as while the beta period is "formally" over, lots of folks are still kicking the tires on the product, and we want you to, as well.

Try and report back soonest.

cheers
jdg

Not a new problem, but I thought that rdc should be able to terminate the application when it finishes sampling. Now there are so many more types of samples to collect, it takes over an hour to complete multiple sampling runs, and it's difficult to arrange the application to terminate on its own shortly after sampling ends and Vtune starts a new copy of the application.

Is the sampling collector configured to terminate the application upon completion of the activity?

Regards,
MrAnderson

Dave,

Yes, I leave the terminate on completion box checked, but I don't know what effect it should have; I've never noticed it to do anything. I have to watch the remote application and kill each instance when the next one starts. It has always been this way, so I guess I shouldn't mention it.

I'm still trying to figure out whether I should be running remote collector, if so, should I use Windows2000 or XP. If not, should it be done with vtl and vnc, neither of which I'm familiar with. Hard to believe after spending so much time with Vtune that it still doesn't become routine.

Hey Tim,

This is the VTune for Linux beta forum, version 3.0. Is your question about this software, or, VTune 7.2 beta?

(On the Linux side, you can use the ActivityController to stop sampling activities.)

jdg

Hi,

just got around installing my beta but was immediately hit by the non support of the 2.6 kernel (2.6.8.1 in my case). Isthere a patch?

Also what is this ntd, paulad and rpcss daemon stuff? What do we need all these daemons for?

Cheers, Fons.

The beta does not, and willnot, support 2.6 kernels. Sorry. :-(

And, you don't need the daemons, but the analyzer does! :-} They are part of a DCOM layer used by the analyzer.

Regards,
MrAnderson

I would REALLY love to have vTune3
work under FedoraCore2. I have downloaded
the course to the 2.6.6 kernel, installed
the patches from the 2.6.x driver kit
(they are badly out of date by the way,
and I had to modify the patch somewhat).

I then got the kernel to work, but I
cannot get the driver to build. First
off it is looking for ksyms.c in
/usr/src/linux-2.6.x/kernel and it is no
longer there it has been moved.

After I pointed it at the correct location,
it builds a vtune_drv.o, but when I try
to insmod that, it complains:

-1 Invalid module format

and dmesg reports

No module found in object.

So I am stuck, very close, but stuck.
I assume the module format has changed
since this module kit was released almost
a year ago. Can someone update this kit
or give me a hint to where I should look
to make the changes myself?

Thanks!
--Wayne Wooten
Pixar Animation Studios

Hey Wayne,
We're checking this out on the engineering side now: stay tuned.

cheers
jdg


This thread is an archive of the postings that were posted during the beta test program for this software. The product is now currently available for sale or evaluation at:

http://www.intel.com/software/products/vtune/vlin

Message Edited by Judy on 02-23-2005 03:37 PM

Message Edited by Judy on 02-23-2005 03:37 PM

is an archive of the postings that were posted during the beta test program for this software?.

Leave a Comment

Please sign in to add a comment. Not a member? Join today