VTune Callgraph viewer

VTune Callgraph viewer

Hi all,

I just installed the Callgraph viewer for Linux, and I can display (console) a result with "vtl view", but when I execute "vtl view -gui" I get the following error:

VTune Performance Analyzer 2.0 for Linux*
Copyright (C) 2000-2003 Intel Corporation. All rights reserved.

Failed to populate consumer

An error occurred during navigation.

Any ideas?

Thanks in advance,
Guillermo Marcus

14 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hey GM,

The last time that happened with me and the cg viewer, there really wasn't any cg data, just sampling. Can you double check, run a cg session on something small, make sure it's there with

$ vtl view

then try

$ vtl view -gui

cheers
jdg

Hi,

I created a simple test program, compiled it with "g++ -g test.cxx -o test" and created an activity with:

vtl activity -c callgraph -app ./test -moi ./test

when I run it, I get the following output:

VTune Performance Analyzer 2.0 for Linux*
Copyright (C) 2000-2003 Intel Corporation. All rights reserved.

The Activity is running.
Tue Nov 23 12:50:30 2004 Reading property files started...
Tue Nov 23 12:50:30 2004 Reading property files done.
Tue Nov 23 12:50:30 2004 Static instrumentation started
Tue Nov 23 12:50:30 2004 All functions instrumentation of module test was skipped.
Tue Nov 23 12:50:30 2004 None instrumentation of module ld-2.3.3.so was skipped.
Tue Nov 23 12:50:30 2004 Exports instrumentation of module libc-2.3.3.so was skipped.
Tue Nov 23 12:50:30 2004 Exports instrumentation of module libgcc_s.so.1 was skipped.
Tue Nov 23 12:50:31 2004 Exports instrumentation of module libm-2.3.3.so was skipped.
Tue Nov 23 12:50:31 2004 Exports instrumentation of module libstdc++.so.5.0.6 was skipped.
Tue Nov 23 12:50:31 2004 Static instrumentation done
Tue Nov 23 12:50:31 2004 Data collection started...
Tue Nov 23 12:50:32 2004 Process Call Graph (MT) Data Collection, id "5665", started writing Call Graph data.

...(output from program supressed)...

Tue Nov 23 12:50:32 2004 Process Call Graph (MT) Data Collection, id "5665", finished writing Call Graph data.

Tue Nov 23 12:50:42 2004 Data collection finished...
Tue Nov 23 12:50:42 2004 Updating call graph database...
Tue Nov 23 12:50:42 2004 Trying to find symbols for module (1 / 4) (apppath)/test/test
Aborted

Similar happens if I try to run it, by example, with "ls" or "gzip". Any suggestions?

Cheers,
GM.

Are you accessing the system remotely via VNC or an X server? If so, try using it locally. If not, you might try uninstalling the viewer and reinstalling it (not the VTune analyzer, just the call graph viewer).

Regards,
MrAnderson

Hi,

No, I am accessing it locally. But the problem seems to be related to the symbol tables, as even a normal, command line view does not provide call information.

GM.

Right. So to check this out, try call graphing 'ls':

vtl activity -c callgraph -app /bin/ls -moi /bin/ls run

then display the results in text form:

vtl view | more

If that works, try the 'vtl view -gui' on this data.

Regards,
MrAnderson

Hi,

Already tried, produces an empty result. However, I am not able to make more tests at this moment, because I am reinstalling the system.

Cheers,
GM.

What OS are you running (i.e. who's distribution and what release)?

Regards,
MrAnderson

Hi,

I was running the test in the Gentoo box (see the other post on how to install it), with Kernel 2.4, and a Xeon 2.66GHz.

Then I decided to try on a Red Hat 7.3 with a 2.4.20 kernel, but unfortunately that machine is a dual Xeon 3.2 with EM64T, so the Vtune 2.0 refuses to run (see my post on EM64T).

Therefore, I reinstalled the other machine (with the Xeon 2.66) with Scientific Linux CERN,a customized version of Red Hat Enterprise Linux 3.0, and wanted to try the VTL3.0 beta on it. But the installer refuses to install. (Just posted an issue on Premier support about this).

I am having serious trouble with your installers. I find myself
spending more time fighting with your app and your installers than doing actual work with it.

GM.

Because the product includes a kernel module for collecting data from the performance monitoring unit of the microprocessor, we have to be very careful about only installing on supported systems. Your difficulties stem from forcing the install on non-supported systems (Gentoo, Scientific Linux CERN). Unfortunately, if you don't have a supported system, you may not be able to use the product.

We are doing our best to add support for other kernels but can only do so much. We appreciate your interest in the product and hope that newer releases will better meet your needs.

Message Edited by DaveA on 12-02-2004 02:16 PM

Regards,
MrAnderson

Hi,

Yes I agree on being careful, I understand the risks involved on installing on unsupported platforms, and this fact as a reason for limiting the supported platforms. But I think the installation process does not allow for the user to make enough choices, and it should be more flexible. This will allow for more and better feedback in the future, and at the end, allow for an extension of the supported platforms if desired.

By example, I would consider Scientific Linux CERN as Red Hat EL 3.0, and I was not especting not to install on it since the Scientific Linux is not a very different distribution from the base RHEL.

Will install on Fedora instead of RHEL, by example, or has to be the commercial, RHEL 3.0 version?

Regards,
GM.

Hey GM,

Well said!

Fedora core 2 will be supported during the second quarter of 2005. (The only 2.6 kernels that we *currently* support are on SuSE releases.)

Also, the installation comments that you've made are excellent, and I personally hope you will continue to report what you need to us, just like you do now.

The operating systems that vtl support are a moving target of course, but therelease notes (default: /opt/intel/vtune/VTLRELEASENOTES.htm) always show precisely what's supported and what's not. They typically include versions of glibc, kernel, etc. I refer to them FREQUENTLY since my memory is not what it should be these days.

:)

Note that with the VTune 3.0 software, installation has gone from what you've seen in vtl 2.0to include two new options, Typical and Silent. Now, an installer will see a choice for Typical or Custom as soon as they start an install. Brief summary:

1) Typical (prompts the user license acceptances, four I think, and only two other requirements,the source trees for /opt/intel/vtune and file tree that Eclipse needs)

2) Custom (the same as the only install option in vtl 2.0)

3) Silent (uses an ascii file for a promptless installation, is NOT presented in a menu like choices 1 and 2 but is described in the documentation)

When you have a chance to examine the 3.0 installation, your suggestions for improvement would be welcome here.

cheers
jdg

Message Edited by jdgallag on 12-03-2004 11:16 AM

Message Edited by jdgallag on 12-03-2004 11:18 AM

Hi,

I have tried installations on 3 different platforms so far: Gentoo (D1), CERN Linux (based on Red Hat 7.3, D2), and Scientific Linux CERN 3 (based on Red Hat Enterprise Linux 3.0, D3).

For this I have used 2 different machines: Machine A is a Xeon 2.66GHz with HT, and Machine B is a dual 3.2GHz Xeon with EM64T.

I tried the following installations:

Vtune 2.0 in (D1, A), does not install, had to do the install hack described in the other thread.

Vtune 2.0 in (D2, B), installs flawlessly but got the EM64T problem described in another thread.

Vtune 3.0 Beta in (D3, A), does not install. I am working on it (but not with the Gentoo-hack trick).

I can say the installers for both versions are equally unflexible so far, and I will strongly suggest that messages like "This is an unsupported platform. Aborting installation." will be replaced with "This is an unsupported platform. Do you want to continue anyway?". Give the user the option to choose to continue, maybe he knows what he is doing.... in any case, he has already being warned.

Cheers,
GM.

Message Edited by guillermo.marcus on 12-03-2004 12:46 PM

It has become difficult to buy plain old 32-bit Xeon boxes. I am at a customer site where they ordered a group of 32-bitters, and got 64-bit. This should be good for Intel, but full support for the 64-bit machines is needed urgently.

Leave a Comment

Please sign in to add a comment. Not a member? Join today