devices not created

devices not created

Hi,

During the installation the VTune devices were not created. I manually created the devices wit

mknod -m 660 /dev/vtune_d c 252 0

mknod -m 660 /dev/vtune_m c 252 1

mknod -m 660 /dev/vtune_p c 252 2

then changed permissions as root:vtune

still it keeps complaining cant open /dev/vtune_d

root is in the vtune group.

any help is appreciated.

reagrds,
kalyan

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

In my limited experience, the most likely reason those devices weren't created is that there is no driver matching your kernel, and the built-in scheme to build a driver failed. Even if your kernel is supported, you need a working gcc installation, and kernel sources installed,to enable the build.
Simply creating those devices won't take care of it. If the driver is correctly installed, changing permissions on the devices may be a way to work around problems with the vtune group membership.
A common problem in the past has been that available kernel sources didn't exactly match the running kernel.
Just yesterday, a procedure was posted along with the download which covers building the driver for one of the red hat EL3 versions, where the vtune driver build script was broken by changes in EL3 subsequent to vtune development.

Thanks for the prompt reply.

I was not able to find what you were referring to "the posted download".
Can you please point to it?

However, I downloaded the VDK for Vtune 2.0 and compiled it manually after I recompiled the kernel to export sys_call_table. Now it works fine.

I tried this on Itanium2 with RHEL 3 U1.

regards,
kalyan

Hey kalyan,

Your latest posting shed some light! VTune 2.0 for Linux does not support RH EL 3.0, so it isn't possible for those particular sampling drivers to be created during the install, which explains the errors you're seeing.

If you examine the install.log that was created during your install, you should see some errors stored regarding that OS,that maybe flashed by too fast pm the display. (Something along the lines of, Hey, this is an unsupported OS, but do you want to continue to install anyway?)

Regardless, if you have a Windows workstation nearby, the VTune for Windows analyzer 7.1 supports data collection for Linux applications on RH EL 3.0 by means of a linux remote agent. If that might work for you, you can download an eval version of that VTune from:

http://www.intel.com/software/products/vtune/vpa/

cheers

jdg

Leave a Comment

Please sign in to add a comment. Not a member? Join today