VTune error mesages

VTune error mesages

Hello all.

I am getting periodic error messages from VTune (with MS VC++ 6 and Intel C++ v7.0). When running a sampling activity and sampling level-1 cache misses and clockticks, I get the following error message in the output window at the bottom of the screen : "The sampling collector failed. There is not enough space on the disk to create a raw data file." In addition I get a message window pop-up saying:" An error occured during drill-down. Cause of error cannot be determined."

My disk has almost 30 gigs free space. I have increased the activity buffer size to 12kb, but that hasn't fixed the problem. This is a problem that crops up seemingly at random. Now what?

13 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Which version of VTune are you using? If anything but 7.1, it might worth giving it a try ASAP.

cheers

jdg

I'm using v6.1 I think my Intel subscription has run out so I don't think I can download and install any of the upgraded versions. Does Intel post service packs or something like that for this product?

Not usually.

The best thing you can do is try the new version, go for the evaluation version. If it clears up your problem, you can report it to us exactly that way on premier.intel.com, that is to say, you own 6.1, you have this problem, but 7.1 cleared up it.

However, if 7.1 does NOT fix the situation, you can report in the problem report that you gave it a try, definitely will speed things up.

Here's the URL for that eval download if you decide to give it a try:

http://www.intel.com/software/products/global/eval.htm#vtune

If you don't want to try it, go ahead and open your premier case anyway to get things rolling.

If you do decide to kick the tires on 7.1, be sure to back up all your projects first because you'll have to remove 6.1 to try 7.1.

cheers

jdg

Also, one more quick thought although it may not apply to you, thought I'd mention it anyway.

If some sort of user quotas are in place on your filesystems, you might be filling one of THOSE up, instead of the actual disk itself. Might account for seeming random nature of the error.

Just a thought!

jdg

Dave:

Are there multiple hard drives on this system? Which drive did you install the analyzer on? How much free space is available on that drive? The analyzer, by default, uses the 'global_data' subdirectory under the VTune installation directory to write raw data. Even if your project is on a drive with lots of free space, if the drive containing the global data directory is nearly full, you will experience intermittent problems. We discovered this only recently in a lab here at Intel.

You can tweak this configuration by changing the VTUNE_GLOBAL_DIR environment variable to point to a directory on the drive with lots of free space.

If you are sure it is unrelated to disk space, please submit an issue at Intel Premier Support.

Message Edited by DaveA on 07-21-2004 04:22 PM

Yeah, sorry. When I replied, I did not realize you were not the original poster.

Has the "An error occured during drill-down. Cause of error cannot be determined" problem got a solution already ?

Did you search http://support.intel.com/support/performancetools/vtune?

Basically, I believe this is an unexpected error. There is no "solution" that I am aware of, since it may occur for multiple reasons. Please submit an issue at Intel Premier Supportand we will investigate.

I experienced such a problem when place project to a subst'ed drive. Perhaps size is calculated incorrectly in that case. VTune 7.2 still contains this bug.

Thanks, ich76! This is a known limitation and is documented in the Release Notes.

Regards,

Since the last message regarding the error message:

There is not enough space on the disk to create a raw data file.

Has any progress been made?

I have a dual P4 with three drives, each drive has more than 40GB of free space.

What is a programmer to do?

Yvon

I'm getting the same problem. I found a mention of this in the file VTune_swdefects.pdf - "Unexpected behaviour may result from a disk full situation". It states that you can configure the location that VTune uses by changing the setting VTUNE_GLOBAL_DIR, but mine is set to C:Program FilesIntelVTuneglobal_data and I've got over 7 GB free on that disk.

Is there a fix for this problem yet? There's not much point listing it as a known limitation in the release notes if there's no way of knowing what's causing it, resolving it or getting round it and the 'limitation' means the product doesn't work.

Leave a Comment

Please sign in to add a comment. Not a member? Join today