-merge-threads with gui

-merge-threads with gui

I am trying to figure out how to get -gui to work with -merge-threads. First activity I tried, I got merging threads by default -- with or without -merge-threads the view was a tree. All the following activities are a forrest, with or without -merge-threads.

I've been unsuccesfully trying to reproduce first activity, and my guess is that I somehow managed to generate callgraph data already merged that time.

My process is:
vtl activity -c callgraph -app ./runtest -moi ../../bin_name
(after test is done) ActivityController -stop
vtl view a?::r? -merge-threads -gui (I tried putting -merge-threads in different places here, and using other options with no success)

So, how do I get gui to merge threads?



4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Great question glebster. I'll ask the engineers, and post here. Stay tuned.



Hey Glebster, here's the engineering response:

1) What you want to do is just not supported; it's not going to work

2) It will be supported in the next release of the plugin software, that will be customized to work with vtl 2.0. That should be available early next year (which is a lot closer than it sounds, let me tell you)

3) I'm reminded by engineering that a good way to get help on vtl is by remembering this format:

$ vtl -help -v

or in this case:

$ vtl -help -v callgraph_gui

(Of course, if you type that in now, you won't see much, but that's really the list of supported options. When the new callgraph plugin viewer is available, that help line should show a lot more!)

Let me know if you'd like to get on the list of folks who will want to see the new callgraph viewer plugin as soon as it's available.



Glebster: will do!



Leave a Comment

Please sign in to add a comment. Not a member? Join today