Vtune analyzer for Linux: running short of memory

Vtune analyzer for Linux: running short of memory

I'm currently evaluating vtune on Linux 1.1 and very keen on buying the product. While evaluating I run into memory problems. Any help will be appreciated.

First I ran the application using vtl activity run. Then I got the activity name using vtl show. Now when I run vtl show I get memory errors. I have 1.5 GB RAM and 5 GB swap space. ANy workarounds will be appreciated.

vtl view a4::r1
VTune Performance Analyzer 1.1 for Linux*
Copyright (C) 2000-2003 Intel Corporation. All rights reserved.

sfdump5: QAlloc.C:351: void *OurMalloc (unsigned int): Assertion `mT->allocedArray.mem != __null' failed.

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Here is more information on the program that I am trying to analyze.

Binary size is .5 MB. Symbol table has 13000 symbols.

Thanks for this interesting note, lokesh123

DEV is extremely interested in knowing more about this problem.

Can you tell us:

1) What Linux distribution you are working with?
2) What upgrades IF ANY have you applied to that default distribution? (kernel, glibc, etc.)



In addition, you can do the following:
vtl pack bug.vxp
You will see file bug.vxp in your directory
File a bug with Vtune Customer Support and provide this bug.vxp as attachment.



I've opened a tracker case for what you're seeing, #16199. This means the DEV will likely have some questions, the kind of which the sooner they are answered the better.

Please send a contact phone number to vtune.sales@intel.com, with the subject FOR JEFF GALLAGHER, and I will see to it that they get it.




To make progress, DEV needs to see the pack and go of this problem. Please send it to vtune.sales@intel.com, with the subject PACK AND GO FOR JEFF GALLAGHER.

Until you do that, no analysis will be possible. Please try to do it soon, as we are very interested in finding out what you're seeing!



You are getting run-time errors from your own memory allocator. You need to figure out why by looking at the particular code that's triggering the assert.


Leave a Comment

Please sign in to add a comment. Not a member? Join today