Problem running vtl command

Problem running vtl command

Hi all! After having installed vtune for linux 1.1 successfully (according to the logs) on Redhat 7.3 (kernel v. 2.4.18-4) and having loaded the driver successfully, I try to execute vtl and I get this result:

Error 0x80030021: Unable to create the VTShell object. Make sure the Shell library is properly installed and registered.

Any ideas?
Thanks!

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Thanks for the INTERESTING post, smaragd! I have not seen this problem before, but I am very curious:

1) To install, did you log on as root or su - ?

2) Sounds like you already know about the install.log which is created automagically during install. The file shows all user decisions, successes, failures. Is there not a single FAILURE listed in there? (Please vi and confirm)

3) What command did you try to get this error? ("vtl" alone should give you a help page; "vtl version" should give you a version. If you try these, do you get the same error?)

4) Is your RH 7.3 a strictly default installation? Or have you upgraded glibc, libc, etc?

If none of these questions reveal something of interest to you, time to open a Premier case! Those support guys eat this stuff up for breakfast.

cheers

jdg

1) I don't know about that. I did not actually make the installation myself as I have not root privileges on that machine.

2) All seems normal.

3) It's the same error always.

4) Again, I don't know about that but since compiling the new sampling driver (that was necessary for that kernel) and installing vtune was smooth, I suppose there shouldn't be a problem with that.

Additional info: as root the vtl command seems to execute normally. Is there some specific path that I should set as a common user, that is already set during the installation, for root? What is that which makes the real difference between executing as root or as a common user and causes this error? (BTW, I belong to user group 'vtune' among others)

Thanks for your interest!

Hi,

The particular error in question, 0x80030021, corresponds to the following error string: "A lock violation has occurred." I have seen this problem in the past--it is usually caused by the user's account being on something like an NFS share. The superuser's account, presumably, is not located on an NFS share and is instead located in /root, which would explain why it works for root.

It is my understanding that running vtl from an NFS share is not supported. You can change the "home" directory for VTune by setting the VTUNE_USER_DIR environment variable to a local directory.

Here's some relevant documentation from the user's guide:

The VTUNE_USER_DIR environment variable determines the home directory where the project, Activities, and Activity results are stored. The default value of this variable is $HOME/.VTune. You may want to change it, for example, if there is not enough space in this directory.

To change the default directory, enter:

set VTUNE_USER_DIR=/temp/VTune #for sh and ksh
export VTUNE_USER_DIR

OR:

setenv VTUNE_USER_DIR=/temp/VTune #for csh

Hope this helps!

Aaron Levinson

Yes, it worked! That made my day! Thank you very much!

Great detective work, aaronl!

cheers

jdg

Leave a Comment

Please sign in to add a comment. Not a member? Join today