Not able to navigate to VS2010 code snippet

Not able to navigate to VS2010 code snippet



I am using Intel VTune amplifier XE 2013 for performance analysis.

I am using light weight hotspot analysis to find the performance by attaching my application preocess with "attach to process" option.

This process is spawning more than one child processes.


When I run the analysis, it gives all the child process analysis data.

But when I double click on perticuler data, I am not able to see its related code in VS2010.

I am able to see only CPU instuctions.


I have installed VS2010 on the same machine.

Please let me konw which steps I am missing which is causing this behaviour.


Thanks in advance

Krupesh D.

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

If you can see assembly code, but not source code, please ensure that you built your application with symbol info and *.pdb files are generated for your binaries. You also need to configure paths to source files, symbol files and binary files in VTune Amplifier XE project settings. If you integrated Intel(R) VTune(TM) Amplifier XE into Visual Studio and run analysis from there, that settings should be taken from Visual Studio project automatically.

Hi Kirill Rogozhin,
Thanks for the information.

Now I am able to navigate to the code for .exe files.
I have added the symbol information (.pdb) for exe as well as .dll files.
Also I have given sorce file directory path in project properties.

One more thing to confirm:
If I navigate for the case of any .exe sorce file , I am able to navigate to its respective (.c or .cpp) file
But if i choose the function of .dll file again I am not able to navigate to source only processor instuctions are shown.

Is this a known behaviour or still I am missing something?

Thanks in advance.

Krupesh D.

Source code from *.dll binaries should be shown as well. Maybe your dlls are located in different directory that is not listed in project settings? Double check that VTune project settings have correct paths to *.dll (binary path), corresponding *.pdb (symbol path) and soruce files (source path). Also check that the code location you're opening is in your code, not in some third party dll.

Leave a Comment

Please sign in to add a comment. Not a member? Join today