Intel vtune amplifier XE 2011 can not write result in locksandwaits sampling mode

Intel vtune amplifier XE 2011 can not write result in locksandwaits sampling mode

 

I have  a licensed copy of Intel VTune XE amplifier 2011 product. I have installed the run-time module of VTune amplifier on a Linux box. I would like to capture the profile data by launching the application with VTune. I could get the profile data in hotspot mode using this setup. But, when I try to use the sampling mode "locksandwaits" or "concurrency" VTune fails in writing the analysis data and terminates abnormally. Apparently, the problem is with the volume of the data that VTune has to process, since the setup work for a smaller number of threads running in my application. When I increase the number of threads to, say 100, the above problem appears.

 

I am wondering if there is a way to increase the size of the analysis data that VTune can process. I would appreciate if you can provide any idea how to narrow down or avoid this problem. Details of my setup:

Linux version: GNU Linux 64 bit, no. of cores: 24.

VTune amplifier XE 2011  , sp1_update2

Thanks in advance,

-Arup

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Please download and try latest VTune(TM) Amplifier XE 2013 Update 2.

What is output after you use below?
amplxe-cl -collect locksandwaits -- your_program

Leave a Comment

Please sign in to add a comment. Not a member? Join today