Installation on Windows crashes

Installation on Windows crashes


I can't install Intel VTune Amplifier XE anymore.

I tried to install the Intel VTune Amplifier XE 2013 Update 2 (alongside an already existing 2011 version), but it ended with the following error message:

    Module C:\Program Files (x86)\Intel\VTune Amplifier XE 2013\bin64\amplxe_tpssmrte_clrprof_1.0.dll failed to register. HRESULT -2147024703. Contact your support personnel.

-2147024703 , which is 0x800700C1 meaning it's not a valid application. I'm using Windows 7 64bit. Because of this error message I choose 'Cancel' and the setup rolled everything back. Since then I can't reinstall 2013 or 2011. It always crashes, when I choose to install the graphical user interface (Command.line interface and Event-based sampling driver can be installed with the above error message, but this message can be ignored). The setup program shows 'Pre-requisite Issues Summary' (which is empty) and then crashes:

    Unhandled exception at 0x774d15de (ntdll.dll) in Setup.exe: 0xC0150010: The activation context being deactivated is not active for the current thread of execution.

    ntdll.dll!_ZwRaiseException@12()  + 0x12 bytes    
     ntdll.dll!_ZwRaiseException@12()  + 0x12 bytes    
     [Frames below may be incorrect and/or missing, no symbols loaded for Setup.exe]    
     user32.dll!_UserCallWinProcCheckWow@32()  + 0x10e bytes    
     user32.dll!_DispatchMessageWorker@8()  + 0xed bytes    
     user32.dll!_DispatchMessageW@4()  + 0xf bytes    
     ntdll.dll!_RtlDosSearchPath_Ustr@36()  + 0xe635 bytes    
     ntdll.dll!_RtlDosSearchPath_Ustr@36()  + 0xe635 bytes    

The same now happens with the setup program for the 2011 version. I can't get it to reintegrate into VS2010 again.

What can I do to fix this?

Alexander Motzkau

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Here are my opinions:
1. You have to use "administrator" user to uninstall/re-install the product.
2. It seemed that setup.exe or other components of VTune(TM) Amplifier XE 2011 are corrupted - so old product can't be uninstalled and new 2012 version can be installed. You may use some Windows cleanup tool to remove XE 2011, then install XE 2013
3. After installing the XE 2013, find and use amplxe-vsreg.exe to install/uninstall integration of VS2010 easily.

1. On this development machine I have all rights. But after the first failed installation I switched to a dedicated Administrator account and got no different result (I still get the error message about the registration of amplxe_tpssmrte_clrprof_1.0.dll and it still crashes when choosing the GUI component).

2. Do you have a recommendation of a cleanup tool, that can clean what the XE 2013 setup apparently did?


PS: I can't log into The username and password seem to be okay (when I use wrong names or passwords, I get an error message saying exactly that), but I'll always be redirected to Isn't this included in the Amplifier XE subscription? (And I get no answers from or the contact form of either...)

Maybe "Windows Installer CleanUp Utility" is a good tool to remove corrupted VTune(TM) Amplifier XE 2011 in your system.

It didn't help at all. I also tried CCleaner and Microsoft FixIt with no success. When I try to install the graphical user interface setup.exe crashes. (It also says there is a XE 2011 version, which I already uninstalled, there is nothing in the registry pointing to XE 2011, so where does it store its information about installations?)

But I finally succeeded: I installed everything but the graphical user interface and said at the beginning, that the installer shouldn't remove the temporary files. There in the setup files you'll find an Installs\ps_he_gui\ps_he_gui.msi. Using msiexec /i ps_he_gui.msi EXTERNALUI=PSET TARGETDIR="C:\...\VTune Amplifier XE 2013" I could install the graphical user interface. With the same option I got to install vs2010-integration.msi (because amplxe-vsreg.exe refused to cooperate, presumably because of this installation method). So for now everything seems to be alright, but for the fact, that now for every update I have to go this way until I reinstall the whole operating system...

Leave a Comment

Please sign in to add a comment. Not a member? Join today