"Failed to finalize the result"

"Failed to finalize the result"

I am using XE 2011. Seit last week I always get the Message while running Hotspot analysis""Failed to finalize the result.  the result you ar opening is empty. this may be caused by an error during data collection. try to re-run the analysis"

I am using Wiindow 7, 64 bit, starting as admin. and when I press "Start Paused" it ieither gnore it and starts immediately starts or produce the above error message.

14 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Maybe your code runs to fast?

Your remark looks strange to me. Sure, the code is fast, but I did it once more with the disabled optimisation (release build). It changed nothing

I mean that sometimes profiled code runs faster than the time resolution of VTune.

What I has to do?

>>...I am using XE 2011. Seit last week I always get the Message while running Hotspot analysis "Failed to finalize the result"...

Boris, What version & update of VTune do you use?

(build 119041) Copyright © 2009-2010 Intel Corporation. All rights reserved.

So, the question is, how long *does* it take for your application to run to completion?  Someone previously correctly posted that if your app runs to completion faster than the resolution of the data collection, you will get no data on your app.  Also, if you press "Start Paused" and never "Resume" data collection, no data will be collected and your results *will* be empty!

What happens if you press "Start" instead of "Start Paused"?

Hi MrAnderson,

>>...So, the question is, how long *does* it take for your application to run to completion?..

You could try a very simple test:

void main( void )

and then profile it with VTune in order to see if VTune results will be saved. Please report results of your experiment.


MrAnderson (Intel) wrote:

What happens if you press "Start" instead of "Start Paused"?

It startes absolut normal and runs, but after I press "stop" or application exit  there are the message.

Alao if I press "Start Paused" it sometijmes starts to run and sometimes closed
Ligtweiht highlight functions OK.

Are there any Windows Update, which can cause the problem? I already deinstalled KB2823324  which did problems with Kaspersky, which was also deaktivated during the run

I did the test with all speed optimisations activated. It is OK

You said, lightweight-hotspots worked - since default sample interval is 1ms (1000 samples per second), but default sample interval of hotspots collection is 10ms. If your application run shortly, especially at interest of function(s), change sample interval of hotspots by Copying from Hotspots and create a new Hotspots analysis on GUI - you can modify sample interval.

Or, simply use in command line - (for example)

amplxe-cl -collect hotspots -knob sampling-interval=2 -- ./your-program

I  ran the application two times once with 2ms second with 50. The result was the same.

However these and previos runs were with the "attach to process". Last tiime I tried it with the "application start" and that functioned also with 2ms.

Previously functioned it also with the "attach to process".

>>>What I has to do?>>>

Sorry for late answer.You can proceed exactly like Peter advised in his post.

Leave a Comment

Please sign in to add a comment. Not a member? Join today