sampling-interval knob with locksandwaits

sampling-interval knob with locksandwaits

Hi,

The VTune documentation http://software.intel.com/sites/products/documentation/doclib/stdxe/2013/amplifierxe/lin/ug_docs/hh_goto.htm#GUID-274DDE84-C483-45A7-B10F-85BD30943EEB.htm lists sampling-interval as one of the knobs that can be used with -collect locksandwaits. However, the following command line:

amplxe-cl -collect locksandwaits -knob sampling-interval=1 -- myapp

produces output:

amplxe: Error: Cannot find knob sampling-interval. Use -knob-list to see available knobs.

I followed the error message advice and used -knob-list=locksandwaits to see available knobs. Only 1 knob was listed, enable-user-tasks.

 

So: The software says sampling-interval is not allowed with locksandwaits, but the documentation says it is allowed. Either there's a bug in the software or there's a bug in the documentation. Which is it?

Thanks,

Greg Bishop

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The problem can be reproduced on my side. But Concurrency and Hotspots worked.

I have escalated this problem to dev team, I will post update soon.

Option "sampling-interval" can only be used for hotspots collection and concurrency collection, Not for locksandwaits again in XE 2013 version - I know it worked for locksandwaits in XE 2011 version. The document will be updated in future release. 

Leave a Comment

Please sign in to add a comment. Not a member? Join today