Error messages when running VTune Amplifier

Error messages when running VTune Amplifier

I am a first user to Vtune Amplifier and I have limited knowledge on it.

I am using Ubuntu 12.04 64bit and Intel Parallel Studio XE 2013.

I can see the messages on the terminal like below when I run amplxe-gui.

** (amplxe-gui:28202): CRITICAL **: os_bar_hide: assertion `OS_IS_BAR (bar)' failed

(amplxe-gui:28202): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

** (amplxe-gui:28202): CRITICAL **: os_bar_set_parent: assertion `OS_IS_BAR (bar)' failed

When closing the program:

(amplxe-gui:28202): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(amplxe-gui:28202): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(amplxe-gui:28202): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

What would be the cause for these messages?

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Probably there were some Gtk libs missed, or version was mismatched in your system.

It will not interfere to collect data and do post-analysis, I think.

Thanks for your reply. Then I will try adjust or reinstall gtk library.

>>** (amplxe-gui:28202): CRITICAL **: os_bar_hide: assertion `OS_IS_BAR (bar)' failed
>>
>>(amplxe-gui:28202): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed
>>
>>** (amplxe-gui:28202): CRITICAL **: os_bar_set_parent: assertion `OS_IS_BAR (bar)' failed
>>
>>When closing the program:
>>
>>(amplxe-gui:28202): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
>>
>>(amplxe-gui:28202): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
>>
>>(amplxe-gui:28202): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
>>...
>>What would be the cause for these messages?

Some internal verifications of GTK library ( I think built in Debug Configuration ) failed and you need to look at source codes of the library. Take into account the VTune is Not responsible for these errors and it simply "passes" these errors to a console.

As it was already said those problems are not related to VTune functionality  itself.Probably in some cases asserts thrown by GTK lib.

My CPU is AMD and OS is Ubuntu 14.04 32 bit. I have met the same problem. Have you solved the peoblem yet?

Thanks.

Original issue was due to GTK* library installation, but VTune command line (amplxe-cl) still can work...

Please try current product VTune(TM) Amplifier XE 2015 which supports Ubuntu* 14.04, and check supported processors for PMU event-based sampling collections, but user-mode sampling still can be used, they are "basic hotspots", "concurrency", and "locksandwaits". 

Leave a Comment

Please sign in to add a comment. Not a member? Join today