amplxe-cl hangs, creates no sampling data

amplxe-cl hangs, creates no sampling data

Quite often, and without any decernable reason, amplxe-cl hotspot collection hangs and creates no sampling data. Any idea what's causing this.

Some folks in this thread: seem to have had the same issue, but no solution there was given.

I am running as root. I have tried running with different programs. It even happens when I profile /bin/ls like so:

<root@TPC-G2-06:/d2/tmp/temp> /opt/intel/vtune_amplifier_xe/bin64/amplxe-cl -collect hotspots /bin/ls

Nothing is written to the cwd. The cwd is writeable.

I've taken an strace of the amplxe-cl run. The output of that can be found here:

If there's any other information that would be helpful, please let me know.

Thanks for your help.

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I should also mention that we're using this processor:

Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz

and this is our Linux Kernel: 2.6.32-279.el6.x86_64

Hi Nathan:

I'm not an expert at reading straces, but it would appear that Amplifier XE is having a problem reading a floating license from your license server.  Has Amplifier XE ever worked on this system?  What type of license do you have and is everything set up correctly?

You can remove the app from the equation with a command like, amplxe-cl -collect advanced-hotspots -duration 5 -r /tmp/results
This will collect 5 seconds worth of data from the system and store it in /tmp/results.  What happens when you try that command? 


Vtune has certainly worked on this system. In fact, it frequently works, then stops working repeatedly. It's possible that it could be a licensing issue, but how do I confirm if this is or is not the issue? Is there some debug logging I can enable?

We have do have a floating license, but I'm quite certain that I'm the only one using it. We are licensed for Linux. I have confirmed that our license server is routable from the machine on which I'm running vtune.

Running your "amplxe-cl -collect advanced-hotspots -duration 5 -r /tmp/results" command exhibits the same hanging issue, so it's not the application.

There is some logging that can be enabled on the server side.  Do you have admin access to the license server?

There is an article that might be helpful, but ultimately it is best to submit an issue at Intel® Premier Support and specify that you are having a licensing issue (in the Category 1 field) with VTune™ Amplifier XE.  We have a special team at Premier support that can troubleshoot licensing issues.  If they determine that it is not a licensing issue, they can forward your issue to the VTune Amplifier XE support team.


I think I've worked through the licensing issues. I believe we ran out of seats. It's unfortunate that amplxe-cl behaves the way that it does, but that's a problem for another day.

My next issue is that my hotspots report doesn't include of malloc, which my program is definitely doing. I suspect that malloc is responsible for a lot of CPU use, and in fact, I've confirmed that this is the case by running oprofile. But Vtune doesn't report malloc at all. I've scoured the documentation for options to hotspot collection that seem like it might aid vtune in reporting malloc use, and I've tried everything I came across, with no luck. Currently, this is what I'm doing:

<root@TPC-G2-06:/d2/tmp/nk> /opt/intel/vtune_amplifier_xe/bin64/amplxe-cl -collect hotspots -follow-child -analyze-system --duration 60 --target-process <myProcessName>

Any idea why Vtune can't identify malloc in the performance profile?



You may try "advanced hotspots" analysis. It dives deeper to system level, where "hotspots" can't access (because it is "user mode").


Leave a Comment

Please sign in to add a comment. Not a member? Join today