The data cannot be displayed: there is no viewpoint applicable for the data

The data cannot be displayed: there is no viewpoint applicable for the data

I have just downloaded the trial of vTune Amplifier XE 2013 r.16 and have tried to do a basic hotspot analysis from with VS 2012.  Unfortunately all I get is the error: "The data cannot be displayed: there is no viewpoint applicable for the data".  I have attached the output below.  I think I have the project options setup correctly. What do I need to get it working?
 

Thanks

 

The database has been cleared, elapsed time is 0.210 seconds.
Warning: Cannot load data file `c:\MyDocs\Progs\MandGen\My Amplifier XE Results - newMand\r012hs\data.0\3500-7056.0.trace' (Data file is corrupted).
Raw data has been loaded to the database, elapsed time is 0.206 seconds.
Data transformations have been finished, elapsed time is 0.000 seconds.
Symbol resolution has been finished, elapsed time is 0.106 seconds.
Deferred data transformations have been finished, elapsed time is 0.005 seconds.
Warning: Cannot find data to precompute. Skipping the precomputation step.
Precomputing frequently used data has been finished, elapsed time is 0.112 seconds.
Data model parameters have been set, elapsed time is 0.019 seconds.
Redundant overtime data has been discarded, elapsed time is 0.012 seconds.
Raw collector data has been discarded, elapsed time is 0.000 seconds.
Finalizing the result took 2.393 seconds.

17 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Just to add a little more information to this.  There are no files in the project directory at all.  (c:\MyDocs\Progs\MandGen\My Amplifier XE Results - newMand\r012hs).

Hi Allan:

Two things: 1) how long does your application execute?  And, 2) please build and use the sample application, tachyon, that comes with the product.  If it works for the sample, then we know it has to do with your app.  If it doesn't work with the sample, then there could be a system configuration issue.

Regards,
MrAnderson

Hi MrAnderson,

Thanks for taking the time to reply.  I just tried the Tachyon sample project and, unfortunately, it doesn't work either.  I just get the same error when trying to analyse hotspots.

My PC setup is as follows:
Windows 8.1 x64
Visual Studio Pro 2012

I have the following plugins also installed: P4VS, VA X, Productivity Power Tools.

Cheers
Allan

 

>>>Warning: Cannot load data file `c:\MyDocs\Progs\MandGen\My Amplifier XE Results - newMand\r012hs\data.0\3500-7056.0.trace' (Data file is corrupted).>>>

I do not think if it is related to your problem, but can you disable AV software during the VTune profiling?

>>>Two things: 1) how long does your application execute?  >>>

IIRC It should be more than single clock interrupt period ~1-3 ms.

Quote:

iliyapolak wrote:

>>>Warning: Cannot load data file `c:\MyDocs\Progs\MandGen\My Amplifier XE Results - newMand\r012hs\data.0\3500-7056.0.trace' (Data file is corrupted).>>>

I do not think if it is related to your problem, but can you disable AV software during the VTune profiling?

I dont have any AV software installed on this machine (as far as I know at least)

Quote:

iliyapolak wrote:

>>>Two things: 1) how long does your application execute?  >>>

IIRC It should be more than single clock interrupt period ~1-3 ms.

 

I forgot to comment on this.  The application runs for a long time, it is based on user input so can run indefinitely if needed.  When trying to profile, it doesn't load the application at all though.

@Allan

Did you try to run under VTune Tachyon example?

Quote:

iliyapolak wrote:

@Allan

Did you try to run under VTune Tachyon example?

Yes, and it gives the same error.

@Peter

Is that possible to ask VTune developers about what is causing this error:The data cannot be displayed: there is no viewpoint applicable for the data.

@ilyapolak, this is a generic error which simply means there is no data.  There is nothing that can be determined from just the error message.

It is very strange, though, since Allan says he is using the Basic Hotspots, which is a software collector.

@Allan, you say it does NOT launch the app?  Ah, Windows* 8.1.  Are you running in desktop (legacy) mode or the new mode?  There are restrictions on how you can profile on Windows 8.1  Please see the release notes and documentation.

See this note from the Release Notes:

1. VTune Amplifier XE supports Basic Hotspots analysis and hardware event-based sampling analysis of Windows Store C# and JavaScript applications on Microsoft Windows 8* via the Attach to Process or Profile System modes. Launch Application mode is not supported. Concurrency and Locks and Waits analysis types are not supported.

Regards,
MrAnderson

Quote:

MrAnderson (Intel) wrote:

@ilyapolak, this is a generic error which simply means there is no data.  There is nothing that can be determined from just the error message.

It is very strange, though, since Allan says he is using the Basic Hotspots, which is a software collector.

@Allan, you say it does NOT launch the app?  Ah, Windows* 8.1.  Are you running in desktop (legacy) mode or the new mode?  There are restrictions on how you can profile on Windows 8.1  Please see the release notes and documentation.

See this note from the Release Notes:

1. VTune Amplifier XE supports Basic Hotspots analysis and hardware event-based sampling analysis of Windows Store C# and JavaScript applications on Microsoft Windows 8* via the Attach to Process or Profile System modes. Launch Application mode is not supported. Concurrency and Locks and Waits analysis types are not supported.

I am running in legacy desktop mode.  I tried attaching to process and I get a little further but I hit the following exception in both Tachyon and my own application:

Unhandled exception at 0x00000000C5026A20 (tpsstool.dll) in newMand.exe: 0xC0000005: 
Access violation reading location 0x0000000000000000.

callstack:
>    tpsstool.dll!00000000c5026a20()    Unknown
     tpsstool.dll!00000000c501c175()    Unknown
     tpsstool.dll!00000000c5016efc()    Unknown
     tpsstool.dll!00000000c50010d2()    Unknown
     pinvm.dll!00000000c328cd23()    Unknown
     pinvm.dll!00000000c328d64e()    Unknown
     pinvm.dll!00000000c302284c()    Unknown

 

I tried running vTune on my laptop with Windows 7 and it all worked well however I really would like it working on my desktop PC.

Thanks

 

 

>>>@ilyapolak, this is a generic error which simply means there is no data.  There is nothing that can be determined from just the error message.>>>

Thanks for the explanation.

>>>Unhandled exception at 0x00000000C5026A20 (tpsstool.dll) in newMand.exe: 0xC0000005: 
Access violation reading location 0x0000000000000000.>>>

Now this is more clearer now.Can you upload the minidump file?

Quote:

iliyapolak wrote:

 

>>>@ilyapolak, this is a generic error which simply means there is no data.  There is nothing that can be determined from just the error message.>>>

Thanks for the explanation.

>>>Unhandled exception at 0x00000000C5026A20 (tpsstool.dll) in newMand.exe: 0xC0000005: 

Access violation reading location 0x0000000000000000.>>>

Now this is more clearer now.Can you upload the minidump file?

 

Yes, please find it attached

Attachments: 

AttachmentSize
Downloadapplication/rar find_hotspots.rar10.08 MB

@Allan

I will look at the dump file later this week.

Leave a Comment

Please sign in to add a comment. Not a member? Join today