VT Amplxe 2016 update 4 not working on Windows 10 Anniversary Edition

VT Amplxe 2016 update 4 not working on Windows 10 Anniversary Edition

I have two Skylake systems that are running Windows 10 Anniversary Edition and neither of them are able to get vtss.sys working.  Eventlog reports the failure: "The vtss service failed to start due to the following error:%%4294967290".  [This magic number is -6 and disassembling vtss.sys, I can see this is used and appears in a number of places in the code (disassembly). The Linux source shows this -6 is VTSS_ERR_NOTFOUND (which is not referenced in the Linux source). ]

I have followed the guidance on the forums and HyperV is off (not checked in programs and features and disabled via BCDEdit).  Various Tools indicate my BIOS has VT enabled.  I am left to a default diagnosis that something is using the PMU resources (Windows 10 AnnEd or something else - Visual Studio 2015 Update 3??) amplxe-sepreg -u, followed by amplxe-sepreg -i -v shows that "Installing and starting VTSS++ driver...FAILED". 


My goal is to be able to use EBS.






Thread Topic: 

Bug Report
12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I just noticed that VS2015 Update 3 is not a supported IDE.  Could this be the problem?

System #1 SurfaceBook 4  System #2 Asus Maximus VIII Gene


Does anyone have amplxe running on Windows 10 Anniversary Ed and can use EBS? If so, do you have VS2015 Update 3 installed?

I can confirm the same issue here: 

C:\Program Files (x86)\IntelSWTools\VTune Amplifier XE\bin32>amplxe-sepreg.exe -i
Installing and starting socperf2_0...
Installing and starting sepdrv4_0...
Installing and starting sepdal...
Installing and starting VTSS++ driver...FAILED

C:\Program Files (x86)\IntelSWTools\VTune Amplifier XE\bin32>

May be somebody from intel could shed some light here?

Windows 10 Anniversary Edition is going to be supported in Intel(R) VTuneTM Amplifier XE 2017 release, which is coming soon.

2016 update 4 version can still be used for event-based sampling without collecting call stacks though.

Same problem here, tried VTune 2017 Beta with Update 1 and got the same error: vtss driver does not work :-(

Unfortunately, still the exact same problem with VTune 2017 final. The software says something about enabling vPMU in the hypervisor and to look at the help, but searching the help file for vPMU yields no result. EBS does not seems to be working?

Hello Alex,

Please follow the help article below to disable the Hyper-V to allow EBS analysis on Windows based system. Make sure to reboot the machine.


Regards, Katya


I've followed these instructions and V-Tune still does not work with Windows 10 Enterprise, version 1607, build 14393.953

Could bitlocker be causing the issue?


Hello Jon,

Please check BIOS VMX (virtualization feature) and try turn it OFF.

Regards, Katya

I have the same problem with VTune 2016 Update 4 and Windows 10

VTune 2016 Update 2 worked really well about 1/2 years ago, but started to crash system into driver-related BSOD after recent Win10 update when trying to run app in advanced hotspot mode with enabled call stack information collection. Once I updated Vtune to 2016 Update 4, it started to report instead that it can't enable advanced capabilities because "problem with the driver (vtss/vtsspp). 

Running "amplxe-sepreg.exe -i" report that it fails to install VTSS++ driver without any additional information (see attached)

Virtualization is disabled in Windows settings (see attached) and BIOS (I disabled both Virtualization and VT for direct I/O; both were active but never caused any problems before).

Any ideas on what could I do next? VTune used to be a brilliant tool when we purchased a licence, but hotspot analysis without call stack heavily reduces its usefulness.

Windows 10 enterprise x64, build 1607 (14393.953), Intel i7-4790 CPU, Dell Optiplex 9020

EDIT: I tried trial version of VTune 2017 Update 3 and it works without any issues. Can you confirm, please, that VTune 2016U4 is not fully compatible with newly updated Windows 10 and the only way to make VTune fully functional again is to purchase VTune 2017?


Downloadimage/png intel2.png8.53 KB
Downloadimage/png intel1.png25.36 KB


I'm still looking for an answer on VTune 2016 / Win10 compatibility and it's somewhat annoying to see no reply for a paid product support request in 3 weeks

With best regards,
Sergei Ozerov

Leave a Comment

Please sign in to add a comment. Not a member? Join today