Problem while installing SEP kernel driver in CentOS

Problem while installing SEP kernel driver in CentOS

Hi,

I am trying to run an advanced hotspot analysis through remote ssh in a CentOS machine. To do this, I need to install the SEP kernel drivers. However, when I run the "insmod-sep" script it gives me this error:

 

./insmod-sep -g root
Checking for PMU arbitration service (PAX) ... detected.
PAX service is accessible to users in group "root".
Checking for socperf driver ... not detected.
The socperf2_0 driver is already loaded! This driver will be used. Please remove the driver and reinstall to load again.
Executing: insmod ./sep4_1-x32_64-3.10.0-327.13.1.el7.x86_64smp.ko
insmod: ERROR: could not insert module ./sep4_1-x32_64-3.10.0-327.13.1.el7.x86_64smp.ko: Invalid parameters

Error:  sep4_1 driver failed to load!

You may need to build sep4_1 driver for your kernel.
Please see the sep4_1 driver README for instructions.

 

I checked the README but it has nothing about the sep4_1 driver. Additionally, I ran the dmesg command and I got this:

[442617.203782] sep4_1: disagrees about version of symbol perf_tp_event
[442617.203809] sep4_1: Unknown symbol perf_tp_event (err -22)

 

Any help would be appreciated.

 

Thanks

 

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Andres,

This error caused by incorrect driver build, the driver must be compiled for the running kernel.

First of all try to rebuild driver on current system and load it again. If you face the problem again it means that during build process incorrect path to kernel headers used. Try to set another kernel header path, commonly it  in:
/lib/modules/kernel_version/build
/usr/src/kernels/kernel_version

And an question: Is the kernel patched?

 

Leave a Comment

Please sign in to add a comment. Not a member? Join today