Vtune advanced-hotspots not capturing entire workload

Vtune advanced-hotspots not capturing entire workload

Hello, 

  I am trying to run vtune 2017 with the advanced-hotspots collection, and it does not seem to be capturing the entire run. Example output:

 

Collection start time     14:13:31 04/10/2017 UTC                                                                                                                                                                                                                                                                                    
Collection stop time      15:09:21 04/10/2017 UTC                                                                                                                                                                    CPU

---
Parameter          r012ah                                           
-----------------  -------------------------------------------------
Name               Intel(R) Xeon(R) E5 Processor code named Jaketown
Frequency          2693511693                                       
Logical CPU Count  32                                               

Summary
-------
Elapsed Time:       3349.496
CPU Time:           3327.408
Average CPU Usage:  0.988   
CPI Rate:           1.043   

LD_LIBRARY_PATH= /home/tools/intel/vtune_amplifier_xe_2017/bin64/amplxe-cl     24505.38s user 220.91s system 100% cpu 6:50:30.18 total

 

So I ran this with 'time' wrapped around it, and time reported the entire thing took 24505 seconds, and it actually ended at approximately 21:00 UTC - but vtune is reporting a collection stop time of 15:09 UTC.

This same command line works with the non-advanced hotspots collection (and took around 32k seconds). This is repeatable - I have not been able to get advanced-hotspots results after many tries. I am not sure what could be going wrong - it seems like the collector is just dying. Sometimes I only get 60-100s of collection range for a 6 hour run.

 

Thanks in advance,

Braxton

 

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The first thing that comes to my mind is Data Limit option. By default VTune stops collection when amount of data reaches 500MB. So if you haven't adjusted this limit it could explain the behavior you are seeing. 

To turn off the data limit add '-data-limit=0' to the amplxe-cl command line.

Also - did you see any errors or warning in console/collection log during the profiling run?

For long runs you should reduce sampling rate so as to avoid approaching data limit or spending much time interrupting collection while saving to disk.

Aaaagh, yes, that was the problem.

 

I had recently upgraded from the 2013 version, which did not have this behavior (or at least the defaults were different).

 

Sure would be nice if the tool said "Hey I stopped collecting because I ran out of allocated space".

Leave a Comment

Please sign in to add a comment. Not a member? Join today