Linux 3.0 support?

Linux 3.0 support?

I'm trying out VTune on Debian Testing (Wheezy), which is now running the Linux 3.0 kernel. VTune doesn't appear to recognize the 3.0 version number.
By hacking the build scripts, I was able to get the kernel module to build with a few tweaks (patch below).The "Advanced Intel Microarchitecture Codename Sandy Bridge" category works.
However, the "Algorithm Analysis" category doesn't work. I get the error message "Error: 3.0 is not a supported linux release". I think this uses the "pin" tool (, and that isn't open source, so I'm stuck here.Anyone have any ideas on getting VTune to work with the 3.0 kernel?
Patch for kernel module:
[diff]diff -ur src/lwpmudrv.c src2/lwpmudrv.c
--- src/lwpmudrv.c	2011-06-14 06:23:32.000000000 -0700
+++ src2/lwpmudrv.c	2011-08-18 21:43:06.424439181 -0700
@@ -138,7 +138,8 @@
 U32                     cur_device             = 0;
 LWPMU_DEVICE            devices                = NULL;
-static  spinlock_t      ioctl_lock            = SPIN_LOCK_UNLOCKED;
+//static  spinlock_t      ioctl_lock            = SPIN_LOCK_UNLOCKED;
+static DEFINE_SPINLOCK(ioctl_lock);
 #define  PMU_DEVICES            2   // pmu, mod
 #define  OTHER_PMU_DEVICES      1   // mod
diff -ur src/output.c src2/output.c
--- src/output.c	2011-06-14 06:23:32.000000000 -0700
+++ src2/output.c	2011-08-18 21:44:00.700436295 -0700
@@ -409,7 +409,8 @@
     outbuf = &(BUFFER_DESC_outbuf(desc));
-    OUTPUT_buffer_lock(outbuf) = SPIN_LOCK_UNLOCKED;
+    //OUTPUT_buffer_lock(outbuf) = SPIN_LOCK_UNLOCKED;
+    spin_lock_init(&OUTPUT_buffer_lock(outbuf));
     for (j = 0; j  
12 posts / 0 new

Latest product VTune Amplifier XE 2011 Update 4 supports Debian* 6 - which kernel version is 2.6.26.

I think that kernel 3.0 based Linux* OShasn't been supported yet.

Regards, Peter

Is there any news update on this? I'm anxiously awaiting VTune for Linux 3 and hope I can use it on Archlinux then.


Not yet.

Also please know the update of supported OSs from website the release notes of this product, or go download site get the release notes, if you already have registered the product.

Regards, Peter

Hi, I did the stupid thing of upgrading Ubuntu to 11.10 when it prompt me. Now I cannot run Vtune anymore. I have to either wait for an updated version or format and roll back at 11.04?


You'll probably need to replace the sep/vtune driver after upgrading Ubuntu, probably by running sudo ./build-driver in your Amplifier installation. You'll need to have installed kernel source, and you may need to help build-driver find it.

I haveIntel VTune Amplifier XE 2011 Update 5, Build Number: 186533 on default installation of Ubuntu 11.10 and Hotspot Analysis doesn't work. I get the message

Error: 3.0 is not a supported linux release

I tried to build the sep driver for my kernel following the instructions at Readme file, but when i do make mrproper i get

/usr/src/linux-headers-3.0.0-12-generic/ubuntu/aufs/Makefile:2: ubuntu/aufs/ No such file or directory
make[2]: *** No rule to make target `ubuntu/aufs/'. Stop.
make[1]: *** [ubuntu/aufs] Error 2
make: *** [_clean_ubuntu] Error 2

Is there anything missing?

Thanks in advance,

You shouldn't have to rebuild the kernel when attempting to build the sep driver. If the build-driver script finds the properly prepared kernel source, it should succeed; then you can run the insmod script.

TimP thank you for your fast reply. I have already built the driver and loaded it with insmod. The building completes without errors, and the loading succeeds; both pax and sep3_4 drivers appear to be loaded when i ran lsmod. But Hotspots analysis still doesn't run. Lightweight Hotspots analysis and processor (Sandy Bridge) specific analysis runs just fine. Is there anything else i could do?


Hm. I can't belive that fixing this vtune issue is so difficult for 3.x kernel .

Should I remember you that kernel version 3.2 is on the way?

any update on getting vtune fully working on ubuntu 11.10?

Linux 3.0 kernel support for algorithmic based analysis types like Hotspots, Concurrency and Locks and Waits was added to Intel VTune Amplifier XE 2011 Update 7. Please explore the following link for more information
Thanks, Dmitry

Leave a Comment

Please sign in to add a comment. Not a member? Join today